aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnome-desktop-sharp20/Makefile3
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp10/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile7
4 files changed, 5 insertions, 11 deletions
diff --git a/x11-toolkits/gnome-desktop-sharp20/Makefile b/x11-toolkits/gnome-desktop-sharp20/Makefile
index 34e43a422053..e09caddb0447 100644
--- a/x11-toolkits/gnome-desktop-sharp20/Makefile
+++ b/x11-toolkits/gnome-desktop-sharp20/Makefile
@@ -13,7 +13,7 @@ COMMENT= GNOME desktop interfaces for the .NET runtime
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-USES= gmake perl5 pathfix pkgconfig tar:bzip2
+USES= gmake mono perl5 pathfix pkgconfig tar:bzip2
USE_PERL5= run
USE_GNOME= gnomepanel gtkhtml3 gtksharp20 gnomesharp20 librsvg2 vte \
libgnomeprintui gtksourceview2 gnomepanel libwnck
@@ -22,5 +22,4 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -e \
's|^#!/usr/bin/perl|#!${PERL}|'
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index 54394acc3067..ff4bcd2b0048 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -12,7 +12,7 @@ COMMENT= GNOME interfaces for the .NET runtime
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake libtool:keepla pathfix perl5 pkgconfig tar:bzip2
+USES= gmake libtool:keepla mono pathfix perl5 pkgconfig tar:bzip2
USE_PERL5= run
USE_GNOME= gnomepanel gtksharp20 librsvg2 vte libgnomeprintui libgnomeui
MAKE_JOBS_UNSAFE= yes
@@ -22,5 +22,4 @@ post-patch:
@${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} -e \
's|^#!/usr/bin/perl|#!${PERL}|'
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-sharp10/Makefile b/x11-toolkits/gtk-sharp10/Makefile
index b0b31e87a5bb..6b698b2a0c94 100644
--- a/x11-toolkits/gtk-sharp10/Makefile
+++ b/x11-toolkits/gtk-sharp10/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
LATEST_LINK= gtk-sharp10
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake pathfix perl5 pkgconfig
+USES= gmake mono pathfix perl5 pkgconfig
USE_PERL5= run
USE_GNOME= gtkhtml3 vte librsvg2 libgnomecanvas \
libgnomeprintui libglade2 libgnomeui
@@ -33,5 +33,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/glib/glue/slist.c ${WRKSRC}/glib/glue/list.c
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
index 0529600e786a..5b06a79ef5dd 100644
--- a/x11-toolkits/gtk-sharp20/Makefile
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -11,14 +11,12 @@ PKGNAMESUFFIX= 20
MAINTAINER= mono@FreeBSD.org
COMMENT= GTK+ and GNOME interfaces for the .NET runtime
-BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
-RUN_DEPENDS= mono:${PORTSDIR}/lang/mono \
- p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= gtk20 libglade2
-USES= gmake libtool:keepla pathfix perl5 pkgconfig shebangfix tar:bzip2
+USES= gmake libtool:keepla mono pathfix perl5 pkgconfig shebangfix tar:bzip2
SHEBANG_FILES= parser/*.pl
USE_PERL5= run
MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
@@ -27,5 +25,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/glib/glue/*.c
-.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
.include <bsd.port.mk>