aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/flu/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-toolkits/flu/Makefile b/x11-toolkits/flu/Makefile
index cc275ee7ad14..b32e329b4b39 100644
--- a/x11-toolkits/flu/Makefile
+++ b/x11-toolkits/flu/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
USE_X_PREFIX= yes
USE_GL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --I=${X11BASE}/include --L=${X11BASE}/lib
USE_GMAKE= yes
@@ -40,4 +40,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Does not compile with GCC 4.2
+.endif
+
+.include <bsd.port.post.mk>