aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/libbonoboui/Makefile1
-rw-r--r--x11-toolkits/libbonoboui/files/patch-bonobo_bonobo-ui-util.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
index 9b6793555b47..157148785e82 100644
--- a/x11-toolkits/libbonoboui/Makefile
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libbonoboui
PORTVERSION= 2.0.3.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.0
diff --git a/x11-toolkits/libbonoboui/files/patch-bonobo_bonobo-ui-util.c b/x11-toolkits/libbonoboui/files/patch-bonobo_bonobo-ui-util.c
new file mode 100644
index 000000000000..7d93d259360a
--- /dev/null
+++ b/x11-toolkits/libbonoboui/files/patch-bonobo_bonobo-ui-util.c
@@ -0,0 +1,18 @@
+--- bonobo/bonobo-ui-util.c.orig Mon Sep 2 11:24:00 2002
++++ bonobo/bonobo-ui-util.c Sat Nov 16 16:38:54 2002
+@@ -539,11 +539,10 @@
+ GNOME_PARAM_GNOME_PREFIX, &prefix, NULL);
+ }
+
+- /* sub-optimal, but what can you do */
+- if (prefix)
+- datadir = g_strdup_printf ("%s/share", prefix);
+- else
+- datadir = g_strdup (BONOBO_DATADIR);
++ g_object_get (G_OBJECT (gnome_program_get ()),
++ GNOME_PARAM_APP_DATADIR, &datadir, NULL);
++ if (!datadir)
++ datadir = g_strdup (BONOBO_DATADIR);
+
+ cl->program = gnome_program_init (
+ doc_id, "2.1",