aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile2
-rw-r--r--x11-toolkits/fpc-gtk/Makefile20
-rw-r--r--x11-toolkits/fpc-gtk1/Makefile20
-rw-r--r--x11-toolkits/fpc-gtk2/Makefile20
4 files changed, 62 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 29a898b96425..37b469b235da 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -26,6 +26,8 @@
SUBDIR += fox14
SUBDIR += fox16
SUBDIR += fpc-forms
+ SUBDIR += fpc-gtk
+ SUBDIR += fpc-gtk2
SUBDIR += fxscintilla
SUBDIR += fxscintilla-fox10
SUBDIR += fxscintilla-fox12
diff --git a/x11-toolkits/fpc-gtk/Makefile b/x11-toolkits/fpc-gtk/Makefile
new file mode 100644
index 000000000000..fe236463162d
--- /dev/null
+++ b/x11-toolkits/fpc-gtk/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: fpc-gtk
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -gtk
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the GTK libraries
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+
+USE_GNOME= gtk12
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/fpc-gtk1/Makefile b/x11-toolkits/fpc-gtk1/Makefile
new file mode 100644
index 000000000000..fe236463162d
--- /dev/null
+++ b/x11-toolkits/fpc-gtk1/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: fpc-gtk
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -gtk
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the GTK libraries
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+
+USE_GNOME= gtk12
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/fpc-gtk2/Makefile b/x11-toolkits/fpc-gtk2/Makefile
new file mode 100644
index 000000000000..cdba6a0c31e1
--- /dev/null
+++ b/x11-toolkits/fpc-gtk2/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: fpc-gtk2
+# Date created: 2006-06-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics lang
+PKGNAMESUFFIX= -gtk2
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Free Pascal interface to the GTK2 libraries
+
+RUN_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+
+USE_GNOME= gtk20
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+
+.include "${MASTERDIR}/Makefile"