aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-back/Makefile10
-rw-r--r--x11-toolkits/gnustep-back/distinfo4
-rw-r--r--x11-toolkits/gnustep-gui/Makefile11
-rw-r--r--x11-toolkits/gnustep-gui/distinfo4
-rw-r--r--x11-toolkits/gnustep-gui/pkg-plist1
5 files changed, 11 insertions, 19 deletions
diff --git a/x11-toolkits/gnustep-back/Makefile b/x11-toolkits/gnustep-back/Makefile
index db20f009e84d..2750c2728b59 100644
--- a/x11-toolkits/gnustep-back/Makefile
+++ b/x11-toolkits/gnustep-back/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnustep-back
-PORTVERSION= 0.9.6
+PORTVERSION= 0.10.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
MASTER_SITE_SUBDIR= core
@@ -38,11 +38,12 @@ USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
MAKEFILE=
MAKE_FLAGS+= OPTFLAG="${CFLAGS} -I${X11BASE}/include"
+BACKVERSION= ${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
BREAKS_IF_PEDANTIC= yes
.if defined(WITH_GNUSTEP_XDPS)
CONFIGURE_ARGS+= --enable-graphics=xdps --with-name=xdps
-PLIST_SUB+= BACK=xdps
+PLIST_SUB+= BACK=xdps-${BACKVERSION}
PLIST_SUB+= USE_XLIB="@comment " USE_XDPS="" USE_ART="@comment "
BACK_SUFFIX?= -xdps
CONFLICTS?= gunstep-back-0.* gunstep-back-art-0.*
@@ -52,13 +53,13 @@ LIB_DEPENDS+= art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2
LIB_DEPENDS+= glitz-glx.1:${PORTSDIR}/graphics/glitz
LIB_DEPENDS+= cairo.1:${PORTSDIR}/graphics/cairo
CONFIGURE_ARGS+= --enable-graphics=art --with-name=art
-PLIST_SUB+= BACK=art USE_XLIB="@comment "
+PLIST_SUB+= BACK=art-${BACKVERSION}
PLIST_SUB+= USE_XLIB="@comment " USE_XDPS="@comment " USE_ART=""
BACK_SUFFIX?= -art
CONFLICTS?= gunstep-back-0.* gunstep-back-xdps-0.*
.else
CONFIGURE_ARGS+= --enable-graphics=xlib --with-name=back
-PLIST_SUB+= BACK=back
+PLIST_SUB+= BACK=back-${BACKVERSION}
PLIST_SUB+= USE_XLIB="" USE_XDPS="@comment " USE_ART="@comment "
CONFLICTS?= gunstep-back-xdps-0.* gunstep-back-art-0.*
.endif
@@ -71,6 +72,7 @@ TARGLIB!= (cd ${PORTSDIR}/${GNUSTEP_OBJC_PORT} && make -V TARGLIB)
ADDITIONAL_LDFLAGS+= -L${TARGLIB}
MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
MAKE_FLAGS+= messages=yes
+PLIST_SUB+= BACKVERSION=${PORTVERSION:C/([0-9])*[.]([0-9]*).*/\1\2/1}
.if ${OSVERSION} < 500000
ADDITIONAL_LDFLAGS+= -L/usr/lib -lcipher
diff --git a/x11-toolkits/gnustep-back/distinfo b/x11-toolkits/gnustep-back/distinfo
index b2cd21daf88c..c2292e4529f4 100644
--- a/x11-toolkits/gnustep-back/distinfo
+++ b/x11-toolkits/gnustep-back/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnustep-back-0.9.6.tar.gz) = 553cdbeebc66fdb53124fc91ea312f2c
-SIZE (gnustep-back-0.9.6.tar.gz) = 820228
+MD5 (gnustep-back-0.10.0.tar.gz) = 8031e2d93b4d3359e167be620d1925fb
+SIZE (gnustep-back-0.10.0.tar.gz) = 814928
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 9cb3f9f80a21..7fe257648c12 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnustep-gui
-PORTVERSION= 0.9.5
+PORTVERSION= 0.10.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
MASTER_SITE_SUBDIR= core
@@ -57,17 +57,8 @@ pre-configure:
.for file in config.guess config.sub install-sh
@${CP} ${PREFIX}/System/Makefiles/${file} ${WRKSRC}
.endfor
- ${REINPLACE_CMD} -e "s|-lphtread|${PTHREAD_LIBS}|g" -e "s|CFLAGS =|CFLAGS+=|" \
- -e "s|-Wall|-Wall ${PTHREAD_CFLAGS:S=""==}|" \
- ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss/Makefile
- ${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
- ${WRKSRC}/Tools/gsnd/GNUmakefile.postamble
.if !defined(NOPORTDOCS)
${REINPLACE_CMD} -e "s|doc=no|doc=yes|" ${WRKSRC}/GNUmakefile
.endif
-test:
- @(cd ${WRKSRC}/Tools/gsnd/portaudio/pa_unix_oss && \
- ${GMAKE} && ./patest)
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnustep-gui/distinfo b/x11-toolkits/gnustep-gui/distinfo
index b06a63d1313d..cc754a4b0b08 100644
--- a/x11-toolkits/gnustep-gui/distinfo
+++ b/x11-toolkits/gnustep-gui/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnustep-gui-0.9.5.tar.gz) = 59c151b1edc2e8e9c1e5aff70569783e
-SIZE (gnustep-gui-0.9.5.tar.gz) = 1876715
+MD5 (gnustep-gui-0.10.0.tar.gz) = 1f35061e045fe7915bfa80ff037dee3a
+SIZE (gnustep-gui-0.10.0.tar.gz) = 1488765
diff --git a/x11-toolkits/gnustep-gui/pkg-plist b/x11-toolkits/gnustep-gui/pkg-plist
index 54723c5fa1ed..5616e1e56bb1 100644
--- a/x11-toolkits/gnustep-gui/pkg-plist
+++ b/x11-toolkits/gnustep-gui/pkg-plist
@@ -644,7 +644,6 @@ System/Library/PostScript/PPD/English.lproj/Generic-PostScript_Printer-Postscrip
System/Library/Services/GSspell.service/GSspell
System/Library/Services/GSspell.service/Resources/Info-gnustep.plist
System/Makefiles/Additional/gui.make
-System/Tools/gnustep_sndd
System/Tools/gopen
System/Tools/make_services
System/Tools/set_show_service