aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/dwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/dwm/Makefile')
-rw-r--r--x11-wm/dwm/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/x11-wm/dwm/Makefile b/x11-wm/dwm/Makefile
index fa6421b4290c..813c6d040b38 100644
--- a/x11-wm/dwm/Makefile
+++ b/x11-wm/dwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dwm
-PORTVERSION= 4.3
+PORTVERSION= 4.4
CATEGORIES= x11-wm
MASTER_SITES= http://www.suckless.org/download/ \
http://schot.a-eskwadraat.nl/files/
@@ -18,11 +18,12 @@ USE_XLIB= yes
MAN1= dwm.1
PLIST_FILES= bin/dwm
+PORTDOCS= LICENSE README
pre-everything::
@${ECHO_MSG} "You can build dwm with your own config.h using the DWM_CONF knob:"
@${ECHO_MSG} "make DWM_CONF=/path/to/dwm/config.h install clean"
- @${ECHO_MSG} "Note: Pre-4.1 config.h-files no longer work."
+ @${ECHO_MSG} "Note: Pre-4.4 config.h-files no longer work."
post-extract:
.if defined(DWM_CONF)
@@ -30,4 +31,12 @@ post-extract:
@${CP} ${DWM_CONF} ${WRKSRC}/config.h
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/LICENSE ${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>