aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-comp-scale/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e17-module-comp-scale/Makefile')
-rw-r--r--x11-wm/e17-module-comp-scale/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/e17-module-comp-scale/Makefile b/x11-wm/e17-module-comp-scale/Makefile
new file mode 100644
index 000000000000..6f3ed8864eb1
--- /dev/null
+++ b/x11-wm/e17-module-comp-scale/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-comp-scale
+# Date created: 21 April 2012
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= comp-scale
+PORTVERSION= 20111128
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/modules/
+PKGNAMEPREFIX= e17-module-
+
+MAINTAINER= magik@roorback.net
+COMMENT= A comp-scale module for Enlightenment 17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>