aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-iiirk
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e17-module-iiirk')
-rw-r--r--x11-wm/e17-module-iiirk/Makefile37
-rw-r--r--x11-wm/e17-module-iiirk/distinfo2
-rw-r--r--x11-wm/e17-module-iiirk/pkg-descr22
-rw-r--r--x11-wm/e17-module-iiirk/pkg-plist56
4 files changed, 117 insertions, 0 deletions
diff --git a/x11-wm/e17-module-iiirk/Makefile b/x11-wm/e17-module-iiirk/Makefile
new file mode 100644
index 000000000000..d942e1d7e80f
--- /dev/null
+++ b/x11-wm/e17-module-iiirk/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e17-module-iiirk
+# Date created: 07 January 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iiirk
+PORTVERSION= 20101003
+CATEGORIES= x11-wm enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/modules/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= A taskbar-like module for e17
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+RUN_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment
+
+DIST_SUBDIR= e17
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje libtool_hack modarch_hack
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/e17-module-iiirk/distinfo b/x11-wm/e17-module-iiirk/distinfo
new file mode 100644
index 000000000000..a5f60ebf5f6f
--- /dev/null
+++ b/x11-wm/e17-module-iiirk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/iiirk-20101003.tar.bz2) = 0df0d593df04f74165cbcdce9322dbd13ffb4359a1232d7dca4cfedf4e19b611
+SIZE (e17/iiirk-20101003.tar.bz2) = 480170
diff --git a/x11-wm/e17-module-iiirk/pkg-descr b/x11-wm/e17-module-iiirk/pkg-descr
new file mode 100644
index 000000000000..1e3bcbc2de76
--- /dev/null
+++ b/x11-wm/e17-module-iiirk/pkg-descr
@@ -0,0 +1,22 @@
+This module act like a taskbar for selected applications only. The purpose of
+this, is having a module behaving like a tray would dock some icons. Due to the
+status of the system tray specification this module don't rely on it, but on
+.desktop and netwm icons only instead.
+
+It's highly recommended to make sure a .desktop match the border you want to
+dock in this module. See http://wiki.enlightenment.org/index.php/E17_and_Efreet#Border_Icons
+for further explanation on how do this matching.
+
+In order to add an icon to the module you have two ways. You can either drag and
+drop the border icon on it, or configure the "Iiirk source". Which is a list of
+.desktop to match automatically.
+
+Once the icon is in the module, a click on it will toggle show/hide on the
+corresponding window. Don't close your windows, what does the window when
+closed is up to the application, not to the module. Use the minimize instead.
+If the option "Hide window from any list when iconified" is enabled, minimize it
+even by using the border button will active the skip window list on it.
+
+Drop an icon outside the box will remove the match on the corresponding .desktop.
+
+WWW: http://www.enlightenment.org/
diff --git a/x11-wm/e17-module-iiirk/pkg-plist b/x11-wm/e17-module-iiirk/pkg-plist
new file mode 100644
index 000000000000..b83fa07779e3
--- /dev/null
+++ b/x11-wm/e17-module-iiirk/pkg-plist
@@ -0,0 +1,56 @@
+lib/enlightenment/modules/iiirk/e-module-iiirk.edj
+lib/enlightenment/modules/iiirk/%%E17_ARCH%%/module.so
+lib/enlightenment/modules/iiirk/module.desktop
+%%NLS%%lib/enlightenment/modules/iiirk/locale/nl/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/fr/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/lt/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/he/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/cs/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/hu/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/pl/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/es/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/hr/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/tr/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/eo/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/it/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/el/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/pt/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/uk/LC_MESSAGES/iiirk.mo
+%%NLS%%lib/enlightenment/modules/iiirk/locale/zh_CN/LC_MESSAGES/iiirk.mo
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/zh_CN
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/uk/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/uk
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/pt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/pt
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/el/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/el
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/it/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/it
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/eo/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/eo
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/tr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/tr
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/hr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/hr
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/es/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/es
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/pl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/pl
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/hu/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/hu
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/cs/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/cs
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/he/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/he
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/lt/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/lt
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/fr/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/fr
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/nl/LC_MESSAGES
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale/nl
+%%NLS%%@dirrm lib/enlightenment/modules/iiirk/locale
+@dirrm lib/enlightenment/modules/iiirk/%%E17_ARCH%%
+@dirrm lib/enlightenment/modules/iiirk
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment