aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/e17-module-screenshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/e17-module-screenshot/Makefile')
-rw-r--r--x11-wm/e17-module-screenshot/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/e17-module-screenshot/Makefile b/x11-wm/e17-module-screenshot/Makefile
new file mode 100644
index 000000000000..06aaaf0fa41c
--- /dev/null
+++ b/x11-wm/e17-module-screenshot/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: e17-module-uptime
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= screenshot
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 module which allows users to take screenshots
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+OPTIONS= IMAGIC "Use ImageMagick" on \
+ SCROT "Use Scrot" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IMAGIC)
+RUN_DEPENDS+= import:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+.if defined(WITH_SCROT)
+RUN_DEPENDS+= scrot:${PORTSDIR}/graphics/scrot
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>