aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/ede
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ede')
-rw-r--r--x11-wm/ede/Makefile15
-rw-r--r--x11-wm/ede/distinfo4
-rw-r--r--x11-wm/ede/files/patch-datas-Makefile11
-rw-r--r--x11-wm/ede/files/patch-datas::startede.in12
-rw-r--r--x11-wm/ede/files/patch-efinder::eglob.cpp25
-rw-r--r--x11-wm/ede/files/patch-elauncher-elauncher.h10
-rw-r--r--x11-wm/ede/files/patch-esvrconf::ehacklist.h389
-rw-r--r--x11-wm/ede/files/patch-evolume-evolume.h11
-rw-r--r--x11-wm/ede/files/patch-evolume-prefs.cpp11
-rw-r--r--x11-wm/ede/pkg-plist64
10 files changed, 101 insertions, 451 deletions
diff --git a/x11-wm/ede/Makefile b/x11-wm/ede/Makefile
index b3b00eec8cfb..abb9a0e28111 100644
--- a/x11-wm/ede/Makefile
+++ b/x11-wm/ede/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ede
-PORTVERSION= 1.0.1.1
+PORTVERSION= 1.0.3
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ede
@@ -16,14 +16,21 @@ COMMENT= Equinox Desktop Environment
LIB_DEPENDS= efltk.2:${PORTSDIR}/x11-toolkits/efltk
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_AUTOCONF_VER= 213
-USE_AUTOMAKE_VER= 14
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on 4.x (sound system)"
+.endif
+
pre-configure:
@cd ${WRKSRC}; ${ACLOCAL}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/ede/distinfo b/x11-wm/ede/distinfo
index cc12b828b8d5..4f5467fb83d9 100644
--- a/x11-wm/ede/distinfo
+++ b/x11-wm/ede/distinfo
@@ -1,2 +1,2 @@
-MD5 (ede-1.0.1.1.tar.gz) = 2588cc90322a069db5c5831bdc0c6c35
-SIZE (ede-1.0.1.1.tar.gz) = 1567011
+MD5 (ede-1.0.3.tar.bz2) = 23e59aa04c48627fa4571cd9fc8aa53c
+SIZE (ede-1.0.3.tar.bz2) = 1373231
diff --git a/x11-wm/ede/files/patch-datas-Makefile b/x11-wm/ede/files/patch-datas-Makefile
new file mode 100644
index 000000000000..a2b46cb6eee6
--- /dev/null
+++ b/x11-wm/ede/files/patch-datas-Makefile
@@ -0,0 +1,11 @@
+--- datas/Makefile.orig Wed Jul 20 12:23:29 2005
++++ datas/Makefile Wed Jul 20 12:23:39 2005
+@@ -10,7 +10,7 @@
+ $(INSTALL_DATA) mime.conf $(DIR)
+ $(INSTALL_DATA) efltk.conf $(DIR)
+ $(MKINSTALLDIRS) $(bindir)
+- $(INSTALL_PROGRAM) startede $(bindir)
++ $(INSTALL_SCRIPT) startede $(bindir)
+
+ uninstall:
+ $(RM) -r $(DIR)
diff --git a/x11-wm/ede/files/patch-datas::startede.in b/x11-wm/ede/files/patch-datas::startede.in
index 9856ae4a2462..dbaed023fbd8 100644
--- a/x11-wm/ede/files/patch-datas::startede.in
+++ b/x11-wm/ede/files/patch-datas::startede.in
@@ -1,17 +1,17 @@
---- datas/startede.in.orig Sat Feb 28 05:31:52 2004
-+++ datas/startede.in Sat Feb 28 05:32:14 2004
+--- datas/startede.in.orig Fri Mar 4 18:44:41 2005
++++ datas/startede.in Wed Jul 20 13:03:33 2005
@@ -32,16 +32,16 @@
fi
# If we have xsetroot than script shoult run it
--if [ ! "$XSETROOT" ]; then
-+if [ ! -z "$XSETROOT" ]; then
+-if [ "$XSETROOT" ]; then
++if [ -z "$XSETROOT" ]; then
$XSETROOT -solid black
fi
# Test if XScreenSaver is somewhere in PATH, if not - don't start it
--if [ ! "$XSSAVER" ]; then
-+if [ ! -z "$XSSAVER" ]; then
+-if [ "$XSSAVER" ]; then
++if [ -z "$XSSAVER" ]; then
xscreensaver -nosplash &
fi
diff --git a/x11-wm/ede/files/patch-efinder::eglob.cpp b/x11-wm/ede/files/patch-efinder::eglob.cpp
deleted file mode 100644
index f602317a5380..000000000000
--- a/x11-wm/ede/files/patch-efinder::eglob.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
---- efinder/eglob.cpp.orig Sat Feb 28 04:48:43 2004
-+++ efinder/eglob.cpp Sat Feb 28 04:49:07 2004
-@@ -74,14 +74,14 @@
-
- static char *ftypes[9] =
- {
-- {"Any kind"},
-- {"Regular"},
-- {"Directory"},
-- {"Symlink"},
-- {"Socket"},
-- {"Block device"},
-- {"Character device"},
-- {"FIFO"},
-+ "Any kind",
-+ "Regular",
-+ "Directory",
-+ "Symlink",
-+ "Socket",
-+ "Block device",
-+ "Character device",
-+ "FIFO",
- NULL
- };
-
diff --git a/x11-wm/ede/files/patch-elauncher-elauncher.h b/x11-wm/ede/files/patch-elauncher-elauncher.h
new file mode 100644
index 000000000000..4184cbab43f2
--- /dev/null
+++ b/x11-wm/ede/files/patch-elauncher-elauncher.h
@@ -0,0 +1,10 @@
+--- elauncher/elauncher.h.orig Wed Jul 20 11:30:44 2005
++++ elauncher/elauncher.h Wed Jul 20 11:32:49 2005
+@@ -13,6 +13,7 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <errno.h>
++#include <signal.h>
+
+ #include <efltk/Fl.h>
+ #include <efltk/Fl_Locale.h>
diff --git a/x11-wm/ede/files/patch-esvrconf::ehacklist.h b/x11-wm/ede/files/patch-esvrconf::ehacklist.h
deleted file mode 100644
index a90950c6097d..000000000000
--- a/x11-wm/ede/files/patch-esvrconf::ehacklist.h
+++ /dev/null
@@ -1,389 +0,0 @@
---- esvrconf/ehacklist.h.orig Sat Feb 28 04:52:22 2004
-+++ esvrconf/ehacklist.h Sat Feb 28 04:16:07 2004
-@@ -18,195 +18,194 @@
-
- // This is from xscreensaver 4.0 XScreenSaver.ad
-
--char hacks[] = " \
-- \"Qix (solid)\" qix -root -solid -segments 100 \n\
-- \"Qix (transparent)\" qix -root -count 4 -solid -transparent \n\
-- \"Qix (linear)\" qix -root -count 5 -solid -transparent \
-- -linear -segments 250 -size 100 \n\
--- mono: \"Qix (xor)\" qix -root -linear -count 5 -size 200 \
-- -spread 30 -segments 75 -solid -xor \n\
-- \
-- \"Attraction (balls)\" attraction -root -mode balls \n\
-- \"Attraction (lines)\" attraction -root -mode lines -points 3
-- -segments 200 \n\
--- \"Attraction (poly)\" attraction -root -mode polygons \n\
-- \"Attraction (splines)\" attraction -root -mode splines -segments \
-- 300 \n\
-- \"Attraction (orbital)\" attraction -root -mode lines -radius 300 \
-- -orbit -vmult 0.5 \n\
-- \
-- pyro -root \n\
-- rocks -root \n\
-- helix -root \n\
-- pedal -root \n\
-- rorschach -root -offset 7 \n\
-- hopalong -root \n\
-- greynetic -root \n\
-- imsmap -root \n\
-- slidescreen -root \n\
-- decayscreen -root \n\
-- jigsaw -root \n\
-- blitspin -root -grab \n\
-- slip -root \n\
-- distort -root \n\
-- spotlight -root \n\
-- \"Ripples (oily)\" ripples -root -oily -light 2 \n\
-- \"Ripples (stir)\" ripples -root -oily -light 2 -stir \n\
-- \"Ripples (desktop)\" ripples -root -water -light 6 \n\
-- hypercube -root \n\
-- hyperball -root \n\
-- halo -root \n\
-- maze -root \n\
-- noseguy -root \n\
-- flame -root \n\
-- lmorph -root \n\
-- deco -root \n\
-- moire -root \n\
-- moire2 -root \n\
-- lightning -root \n\
-- strange -root \n\
-- spiral -root \n\
-- laser -root \n\
-- grav -root \n\
-- \"Grav (trails)\" grav -root -trail -decay \n\
-- drift -root \n\
-- ifs -root \n\
-- julia -root \n\
-- penrose -root \n\
-- sierpinski -root \n\
-- braid -root \n\
-- galaxy -root \n\
-- bouboule -root \n\
-- swirl -root \n\
-- flag -root \n\
-- sphere -root \n\
-- forest -root \n\
-- lisa -root \n\
-- lissie -root \n\
-- goop -root -max-velocity 0.5 -elasticity \
-- 0.9 \n\
-- starfish -root \n\
-- \"Starfish (blob)\" starfish -root -blob \n\
-- munch -root \n\
-- fadeplot -root \n\
-- coral -root -delay 0 \n\
-- mountain -root \n\
-- triangle -root -delay 1 \n\
-- worm -root \n\
-- rotor -root \n\
-- ant -root \n\
-- demon -root \n\
-- loop -root \n\
-- vines -root \n\
-- kaleidescope -root \n\
-- xjack -root \n\
-- xlyap -root -randomize \n\
-- cynosure -root \n\
-- flow -root \n\
-- epicycle -root \n\
-- interference -root \n\
-- truchet -root -randomize \n\
-- bsod -root \n\
-- crystal -root \n\
-- discrete -root \n\
-- kumppa -root \n\
-- rd-bomb -root \n\
-- \"RD-Bomb (mobile)\" rd-bomb -root -speed 1 -size 0.1 \n\
-- sonar -root \n\
-- t3d -root \n\
-- penetrate -root \n\
-- deluxe -root \n\
-- compass -root \n\
-- squiral -root \n\
-- xflame -root \n\
-- wander -root \n\
-- \"Wander (spots)\" wander -root -advance 0 -size 10 -circles \
-- -length 10000 -reset 100000 \n\
-- critical -root \n\
-- phosphor -root \n\
-- xmatrix -root \n\
-- petri -root -size 2 -count 20 \n\
-- \"Petri 2\" petri -root -minlifespeed 0.02 \
-- -maxlifespeed 0.03 -minlifespan 1 \
-- -maxlifespan 1 -instantdeathchan 0 \
-- -minorchan 0 -anychan 0.3 \n\
-- shadebobs -root \n\
-- ccurve -root \n\
-- blaster -root \n\
-- bumps -root \n\
-- xteevee -root \n\
-- xspirograph -root \n\
-- nerverot -root \n\
--- \"NerveRot (dense)\" nerverot -root -count 1000 \n\
--- \"NerveRot (thick)\" nerverot -root -count 100 -line-width 4 \
-- -max-nerve-radius 0.8 -nervousness 0.5 -db \n\
-- xrayswarm -root \n\
--- \"Zoom (Fatbits)\" zoom -root \n\
-- \"Zoom (Lenses)\" zoom -root -lenses \n\
-- rotzoomer -root \n\
--- \"RotZoomer (mobile)\" rotzoomer -root -move \n\
--- \"RotZoomer (sweep)\" rotzoomer -root -sweep \n\
-- whirlwindwarp -root \n\
-- \"WhirlyGig\" whirlygig -root \n\
-- \"SpeedMine\" speedmine -root \n\
-- \"SpeedWorm\" speedmine -root -worm \n\
-- vermiculate -root \n\
-- color: bubbles -root \n\
-- default-n: webcollage -root \n\
-- default-n: \"WebCollage (whacked)\" \
-- webcollage -root -filter \
-- 'vidwhacker -stdin -stdout' \n\
--- default-n: vidwhacker -root \n\
-- \
-- GL: gears -root \n\
-- GL: \"Gears (planetary)\" gears -root -planetary \n\
-- GL: superquadrics -root \n\
-- GL: morph3d -root \n\
-- GL: cage -root \n\
-- GL: moebius -root \n\
-- GL: stairs -root \n\
-- GL: pipes -root \n\
-- GL: sproingies -root \n\
-- GL: rubik -root \n\
-- GL: atlantis -root \n\
-- GL: lament -root \n\
-- GL: bubble3d -root \n\
-- GL: glplanet -root \n\
-- GL: pulsar -root \n\
--- GL: \"Pulsar (textures)\" \
-- pulsar -root -texture -mipmap \
-- -texture_quality -light -fog \n\
--- GL: extrusion -root \n\
-- GL: sierpinski3d -root \n\
-- GL: menger -root \n\
-- GL: \"GFlux\" gflux -root \n\
-- GL: \"GFlux (grab)\" gflux -root -mode grab \n\
-- GL: stonerview -root \n\
-- GL: starwars -root \n\
-- GL: gltext -root \n\
-- GL: \"GLText (clock)\" gltext -text \"%A%n%d %b %Y%n%r\" -root \n\
-- GL: \"Molecule\" molecule -root \n\
-- GL: \"Molecule (lumpy)\" molecule -root -no-bonds -no-labels \n\
-- GL: dangerball -root \n\
-- GL: circuit -root \n\
-- GL: engine -root \n\
-- GL: flipscreen3d -root \n\
-- \
--- xdaliclock -root -builtin3 -cycle \n\
--- default-n: xearth -nofork -nostars -ncolors 50 \
-- -night 3 -wait 0 -timewarp 400.0 -pos \
-- sunrel/38/-30 \n\
--- xplanetbg -xscreensaver -moonside \
-- -markerfile earth -wait 1 -timewarp 400 \n\
--- ssystem -fullscreen :32 \n\
--- xmountains -b -M -Z 0 -r 1 \n\
--- \"XMountains (top)\" xmountains -b -M -Z 0 -r 1 -m \n\
--- xaos -fullscreen -autopilot \
-- -incoloring -1 -outcoloring -1 \n\
--- xfishtank -d -s \n\
--- xsnow \n\
--- goban -root \n\
--- electricsheep \n\
--- cosmos -root \n\
--- GL: sphereEversion --root \n";
--
-+char hacks[] = " "\
-+" \"Qix (solid)\" qix -root -solid -segments 100 \n"\
-+" \"Qix (transparent)\" qix -root -count 4 -solid -transparent \n"\
-+" \"Qix (linear)\" qix -root -count 5 -solid -transparent "\
-+" -linear -segments 250 -size 100 \n"\
-+"- mono: \"Qix (xor)\" qix -root -linear -count 5 -size 200 "\
-+" -spread 30 -segments 75 -solid -xor \n"\
-+" "\
-+" \"Attraction (balls)\" attraction -root -mode balls \n"\
-+" \"Attraction (lines)\" attraction -root -mode lines -points 3 "\
-+" -segments 200 \n"\
-+"- \"Attraction (poly)\" attraction -root -mode polygons \n"\
-+" \"Attraction (splines)\" attraction -root -mode splines -segments "\
-+" 300 \n"\
-+" \"Attraction (orbital)\" attraction -root -mode lines -radius 300 "\
-+" -orbit -vmult 0.5 \n"\
-+" "\
-+" pyro -root \n"\
-+" rocks -root \n"\
-+" helix -root \n"\
-+" pedal -root \n"\
-+" rorschach -root -offset 7 \n"\
-+" hopalong -root \n"\
-+" greynetic -root \n"\
-+" imsmap -root \n"\
-+" slidescreen -root \n"\
-+" decayscreen -root \n"\
-+" jigsaw -root \n"\
-+" blitspin -root -grab \n"\
-+" slip -root \n"\
-+" distort -root \n"\
-+" spotlight -root \n"\
-+" \"Ripples (oily)\" ripples -root -oily -light 2 \n"\
-+" \"Ripples (stir)\" ripples -root -oily -light 2 -stir \n"\
-+" \"Ripples (desktop)\" ripples -root -water -light 6 \n"\
-+" hypercube -root \n"\
-+" hyperball -root \n"\
-+" halo -root \n"\
-+" maze -root \n"\
-+" noseguy -root \n"\
-+" flame -root \n"\
-+" lmorph -root \n"\
-+" deco -root \n"\
-+" moire -root \n"\
-+" moire2 -root \n"\
-+" lightning -root \n"\
-+" strange -root \n"\
-+" spiral -root \n"\
-+" laser -root \n"\
-+" grav -root \n"\
-+" \"Grav (trails)\" grav -root -trail -decay \n"\
-+" drift -root \n"\
-+" ifs -root \n"\
-+" julia -root \n"\
-+" penrose -root \n"\
-+" sierpinski -root \n"\
-+" braid -root \n"\
-+" galaxy -root \n"\
-+" bouboule -root \n"\
-+" swirl -root \n"\
-+" flag -root \n"\
-+" sphere -root \n"\
-+" forest -root \n"\
-+" lisa -root \n"\
-+" lissie -root \n"\
-+" goop -root -max-velocity 0.5 -elasticity "\
-+" 0.9 \n"\
-+" starfish -root \n"\
-+" \"Starfish (blob)\" starfish -root -blob \n"\
-+" munch -root \n"\
-+" fadeplot -root \n"\
-+" coral -root -delay 0 \n"\
-+" mountain -root \n"\
-+" triangle -root -delay 1 \n"\
-+" worm -root \n"\
-+" rotor -root \n"\
-+" ant -root \n"\
-+" demon -root \n"\
-+" loop -root \n"\
-+" vines -root \n"\
-+" kaleidescope -root \n"\
-+" xjack -root \n"\
-+" xlyap -root -randomize \n"\
-+" cynosure -root \n"\
-+" flow -root \n"\
-+" epicycle -root \n"\
-+" interference -root \n"\
-+" truchet -root -randomize \n"\
-+" bsod -root \n"\
-+" crystal -root \n"\
-+" discrete -root \n"\
-+" kumppa -root \n"\
-+" rd-bomb -root \n"\
-+" \"RD-Bomb (mobile)\" rd-bomb -root -speed 1 -size 0.1 \n"\
-+" sonar -root \n"\
-+" t3d -root \n"\
-+" penetrate -root \n"\
-+" deluxe -root \n"\
-+" compass -root \n"\
-+" squiral -root \n"\
-+" xflame -root \n"\
-+" wander -root \n"\
-+" \"Wander (spots)\" wander -root -advance 0 -size 10 -circles "\
-+" -length 10000 -reset 100000 \n"\
-+" critical -root \n"\
-+" phosphor -root \n"\
-+" xmatrix -root \n"\
-+" petri -root -size 2 -count 20 \n"\
-+" \"Petri 2\" petri -root -minlifespeed 0.02 "\
-+" -maxlifespeed 0.03 -minlifespan 1 "\
-+" -maxlifespan 1 -instantdeathchan 0 "\
-+" -minorchan 0 -anychan 0.3 \n"\
-+" shadebobs -root \n"\
-+" ccurve -root \n"\
-+" blaster -root \n"\
-+" bumps -root \n"\
-+" xteevee -root \n"\
-+" xspirograph -root \n"\
-+" nerverot -root \n"\
-+"- \"NerveRot (dense)\" nerverot -root -count 1000 \n"\
-+"- \"NerveRot (thick)\" nerverot -root -count 100 -line-width 4 "\
-+" -max-nerve-radius 0.8 -nervousness 0.5 -db \n"\
-+" xrayswarm -root \n"\
-+"- \"Zoom (Fatbits)\" zoom -root \n"\
-+" \"Zoom (Lenses)\" zoom -root -lenses \n"\
-+" rotzoomer -root \n"\
-+"- \"RotZoomer (mobile)\" rotzoomer -root -move \n"\
-+"- \"RotZoomer (sweep)\" rotzoomer -root -sweep \n"\
-+" whirlwindwarp -root \n"\
-+" \"WhirlyGig\" whirlygig -root \n"\
-+" \"SpeedMine\" speedmine -root \n"\
-+" \"SpeedWorm\" speedmine -root -worm \n"\
-+" vermiculate -root \n"\
-+" color: bubbles -root \n"\
-+" default-n: webcollage -root \n"\
-+" default-n: \"WebCollage (whacked)\" "\
-+" webcollage -root -filter "\
-+" 'vidwhacker -stdin -stdout' \n"\
-+"- default-n: vidwhacker -root \n"\
-+" "\
-+" GL: gears -root \n"\
-+" GL: \"Gears (planetary)\" gears -root -planetary \n"\
-+" GL: superquadrics -root \n"\
-+" GL: morph3d -root \n"\
-+" GL: cage -root \n"\
-+" GL: moebius -root \n"\
-+" GL: stairs -root \n"\
-+" GL: pipes -root \n"\
-+" GL: sproingies -root \n"\
-+" GL: rubik -root \n"\
-+" GL: atlantis -root \n"\
-+" GL: lament -root \n"\
-+" GL: bubble3d -root \n"\
-+" GL: glplanet -root \n"\
-+" GL: pulsar -root \n"\
-+"- GL: \"Pulsar (textures)\" "\
-+" pulsar -root -texture -mipmap "\
-+" -texture_quality -light -fog \n"\
-+"- GL: extrusion -root \n"\
-+" GL: sierpinski3d -root \n"\
-+" GL: menger -root \n"\
-+" GL: \"GFlux\" gflux -root \n"\
-+" GL: \"GFlux (grab)\" gflux -root -mode grab \n"\
-+" GL: stonerview -root \n"\
-+" GL: starwars -root \n"\
-+" GL: gltext -root \n"\
-+" GL: \"GLText (clock)\" gltext -text \"%A%n%d %b %Y%n%r\" -root \n"\
-+" GL: \"Molecule\" molecule -root \n"\
-+" GL: \"Molecule (lumpy)\" molecule -root -no-bonds -no-labels \n"\
-+" GL: dangerball -root \n"\
-+" GL: circuit -root \n"\
-+" GL: engine -root \n"\
-+" GL: flipscreen3d -root \n"\
-+" "\
-+"- xdaliclock -root -builtin3 -cycle \n"\
-+"- default-n: xearth -nofork -nostars -ncolors 50 "\
-+" -night 3 -wait 0 -timewarp 400.0 -pos "\
-+" sunrel/38/-30 \n"\
-+"- xplanetbg -xscreensaver -moonside "\
-+" -markerfile earth -wait 1 -timewarp 400 \n"\
-+"- ssystem -fullscreen :32 \n"\
-+"- xmountains -b -M -Z 0 -r 1 \n"\
-+"- \"XMountains (top)\" xmountains -b -M -Z 0 -r 1 -m \n"\
-+"- xaos -fullscreen -autopilot "\
-+" -incoloring -1 -outcoloring -1 \n"\
-+"- xfishtank -d -s \n"\
-+"- xsnow \n"\
-+"- goban -root \n"\
-+"- electricsheep \n"\
-+"- cosmos -root \n"\
-+"- GL: sphereEversion --root \n";
diff --git a/x11-wm/ede/files/patch-evolume-evolume.h b/x11-wm/ede/files/patch-evolume-evolume.h
new file mode 100644
index 000000000000..e0411d91e685
--- /dev/null
+++ b/x11-wm/ede/files/patch-evolume-evolume.h
@@ -0,0 +1,11 @@
+--- evolume/evolume.h.orig Wed Jul 20 11:38:26 2005
++++ evolume/evolume.h Wed Jul 20 11:38:46 2005
+@@ -13,7 +13,7 @@
+ #include <string.h>
+ #include <sys/errno.h>
+ #include <fcntl.h>
+-#include <linux/soundcard.h>
++#include <sys/soundcard.h>
+ #include <sys/ioctl.h>
+ }
+
diff --git a/x11-wm/ede/files/patch-evolume-prefs.cpp b/x11-wm/ede/files/patch-evolume-prefs.cpp
new file mode 100644
index 000000000000..7fb084c0ad06
--- /dev/null
+++ b/x11-wm/ede/files/patch-evolume-prefs.cpp
@@ -0,0 +1,11 @@
+--- evolume/prefs.cpp.orig Wed Jul 20 12:01:37 2005
++++ evolume/prefs.cpp Wed Jul 20 12:01:44 2005
+@@ -4,7 +4,7 @@
+ // See COPYING for details.
+
+ #include "prefs.h"
+-#include <malloc.h>
++//#include <malloc.h>
+ #include <efltk/Fl_Item.h>
+ #include <efltk/filename.h>
+ #include <efltk/Fl_Locale.h>
diff --git a/x11-wm/ede/pkg-plist b/x11-wm/ede/pkg-plist
index 4f35c9454756..ddd023a48515 100644
--- a/x11-wm/ede/pkg-plist
+++ b/x11-wm/ede/pkg-plist
@@ -3,19 +3,20 @@ bin/econtrol
bin/edewm
bin/edisplayconf
bin/efinder
-bin/ehelpbook
bin/eiconman
bin/eiconsconf
bin/einstaller
+bin/ekeyconf
+bin/elauncher
bin/emenueditor
bin/epanelconf
bin/erun
bin/esvrconf
bin/etimedate
bin/etip
+bin/evolume
bin/ewmconf
bin/eworkpanel
-bin/glob
bin/startede
share/ede/.ede/desktop/Terminal.desktop
share/ede/.ede/ede.conf
@@ -37,10 +38,19 @@ share/ede/.ede/schemes/None.scheme
share/ede/.ede/schemes/Tubus.scheme
share/ede/.ede/schemes/TypicalBrown.scheme
share/ede/.ede/wmanager.conf
+share/ede/doc/authors.html
+share/ede/doc/changelog.html
+share/ede/doc/copying.html
share/ede/doc/ede-small.gif
+share/ede/doc/ede.png
+share/ede/doc/getede.png
+share/ede/doc/help.html
share/ede/doc/index.html
+share/ede/doc/logoinvert100.png
+share/ede/doc/style.css
share/ede/icons/16x16/3floppy_mount.png
share/ede/icons/16x16/3floppy_unmount.png
+share/ede/icons/16x16/about.png
share/ede/icons/16x16/access.png
share/ede/icons/16x16/access2.png
share/ede/icons/16x16/applix.png
@@ -75,6 +85,7 @@ share/ede/icons/16x16/decrypted.png
share/ede/icons/16x16/desktop.png
share/ede/icons/16x16/document.png
share/ede/icons/16x16/down.png
+share/ede/icons/16x16/econtrol.png
share/ede/icons/16x16/edit.png
share/ede/icons/16x16/editcopy.png
share/ede/icons/16x16/editcut.png
@@ -82,6 +93,9 @@ share/ede/icons/16x16/editdelete.png
share/ede/icons/16x16/editpaste.png
share/ede/icons/16x16/editshred.png
share/ede/icons/16x16/edittrash.png
+share/ede/icons/16x16/efinder.png
+share/ede/icons/16x16/ehelpbook.png
+share/ede/icons/16x16/emenueditor.png
share/ede/icons/16x16/empty2.png
share/ede/icons/16x16/empty_ascii.png
share/ede/icons/16x16/encrypted.png
@@ -160,6 +174,7 @@ share/ede/icons/16x16/linuxconf.png
share/ede/icons/16x16/lock.png
share/ede/icons/16x16/lockoverlay.png
share/ede/icons/16x16/log.png
+share/ede/icons/16x16/logout.png
share/ede/icons/16x16/mail_generic.png
share/ede/icons/16x16/make.png
share/ede/icons/16x16/midi.png
@@ -487,6 +502,7 @@ share/ede/programs/System/Kterm.desktop
share/ede/programs/System/UNIX-regular.desktop
share/ede/programs/System/UNIX.desktop
share/ede/programs/System/Vnterm.desktop
+share/ede/programs/System/rxvt.desktop
share/ede/programs/Utilities/.directory
share/ede/programs/Utilities/calc.desktop
share/ede/programs/Utilities/finder.desktop
@@ -494,37 +510,38 @@ share/ede/programs/Utilities/fstabedit.desktop
share/ede/programs/Utilities/sccalc.desktop
share/ede/programs/Utilities/tips.desktop
share/ede/programs/Utilities/xmag.desktop
-share/locale/fi/LC_MESSAGES/edewm.mo
-share/locale/id/LC_MESSAGES/ecolorconf.mo
-share/locale/id/LC_MESSAGES/econtrol.mo
-share/locale/id/LC_MESSAGES/edewm.mo
-share/locale/id/LC_MESSAGES/edisplayconf.mo
-share/locale/id/LC_MESSAGES/efinder.mo
-share/locale/id/LC_MESSAGES/ehelpbook.mo
-share/locale/id/LC_MESSAGES/eiconman.mo
-share/locale/id/LC_MESSAGES/eiconsconf.mo
-share/locale/id/LC_MESSAGES/emenueditor.mo
-share/locale/id/LC_MESSAGES/epanelconf.mo
-share/locale/id/LC_MESSAGES/erun.mo
-share/locale/id/LC_MESSAGES/etimedate.mo
-share/locale/id/LC_MESSAGES/etip.mo
-share/locale/id/LC_MESSAGES/ewmconf.mo
-share/locale/id/LC_MESSAGES/eworkpanel.mo
+share/locale/hu/LC_MESSAGES/ecolorconf.mo
+share/locale/hu/LC_MESSAGES/econtrol.mo
+share/locale/hu/LC_MESSAGES/edewm.mo
+share/locale/hu/LC_MESSAGES/edisplayconf.mo
+share/locale/hu/LC_MESSAGES/efinder.mo
+share/locale/hu/LC_MESSAGES/eiconman.mo
+share/locale/hu/LC_MESSAGES/eiconsconf.mo
+share/locale/hu/LC_MESSAGES/einstaller.mo
+share/locale/hu/LC_MESSAGES/elauncher.mo
+share/locale/hu/LC_MESSAGES/emenueditor.mo
+share/locale/hu/LC_MESSAGES/epanelconf.mo
+share/locale/hu/LC_MESSAGES/esvrconf.mo
+share/locale/hu/LC_MESSAGES/etimedate.mo
+share/locale/hu/LC_MESSAGES/evolume.mo
+share/locale/hu/LC_MESSAGES/ewmconf.mo
+share/locale/hu/LC_MESSAGES/eworkpanel.mo
share/locale/ru/LC_MESSAGES/ecolorconf.mo
share/locale/ru/LC_MESSAGES/econtrol.mo
share/locale/ru/LC_MESSAGES/edewm.mo
share/locale/ru/LC_MESSAGES/edisplayconf.mo
share/locale/ru/LC_MESSAGES/efinder.mo
-share/locale/ru/LC_MESSAGES/ehelpbook.mo
share/locale/ru/LC_MESSAGES/eiconman.mo
share/locale/ru/LC_MESSAGES/eiconsconf.mo
share/locale/ru/LC_MESSAGES/einstaller.mo
+share/locale/ru/LC_MESSAGES/elauncher.mo
share/locale/ru/LC_MESSAGES/emenueditor.mo
share/locale/ru/LC_MESSAGES/epanelconf.mo
share/locale/ru/LC_MESSAGES/erun.mo
share/locale/ru/LC_MESSAGES/esvrconf.mo
share/locale/ru/LC_MESSAGES/etimedate.mo
share/locale/ru/LC_MESSAGES/etip.mo
+share/locale/ru/LC_MESSAGES/evolume.mo
share/locale/ru/LC_MESSAGES/ewmconf.mo
share/locale/ru/LC_MESSAGES/eworkpanel.mo
share/locale/sk/LC_MESSAGES/ecolorconf.mo
@@ -532,25 +549,26 @@ share/locale/sk/LC_MESSAGES/econtrol.mo
share/locale/sk/LC_MESSAGES/edewm.mo
share/locale/sk/LC_MESSAGES/edisplayconf.mo
share/locale/sk/LC_MESSAGES/efinder.mo
-share/locale/sk/LC_MESSAGES/ehelpbook.mo
share/locale/sk/LC_MESSAGES/eiconman.mo
share/locale/sk/LC_MESSAGES/eiconsconf.mo
share/locale/sk/LC_MESSAGES/einstaller.mo
+share/locale/sk/LC_MESSAGES/elauncher.mo
share/locale/sk/LC_MESSAGES/emenueditor.mo
share/locale/sk/LC_MESSAGES/epanelconf.mo
share/locale/sk/LC_MESSAGES/erun.mo
share/locale/sk/LC_MESSAGES/esvrconf.mo
share/locale/sk/LC_MESSAGES/etimedate.mo
share/locale/sk/LC_MESSAGES/etip.mo
+share/locale/sk/LC_MESSAGES/evolume.mo
share/locale/sk/LC_MESSAGES/ewmconf.mo
share/locale/sk/LC_MESSAGES/eworkpanel.mo
share/locale/sr/LC_MESSAGES/ecolorconf.mo
share/locale/sr/LC_MESSAGES/econtrol.mo
share/locale/sr/LC_MESSAGES/edewm.mo
share/locale/sr/LC_MESSAGES/edisplayconf.mo
-share/locale/sr/LC_MESSAGES/ehelpbook.mo
share/locale/sr/LC_MESSAGES/eiconman.mo
share/locale/sr/LC_MESSAGES/eiconsconf.mo
+share/locale/sr/LC_MESSAGES/elauncher.mo
share/locale/sr/LC_MESSAGES/emenueditor.mo
share/locale/sr/LC_MESSAGES/epanelconf.mo
share/locale/sr/LC_MESSAGES/erun.mo
@@ -572,11 +590,7 @@ share/locale/sr/LC_MESSAGES/eworkpanel.mo
@dirrm share/ede/icons/16x16
@dirrm share/ede/icons
@dirrm share/ede/doc
-@dirrm share/ede/apps
@dirrm share/ede/.ede/schemes
-@dirrm share/ede/.ede/programs
-@dirrm share/ede/.ede/favourites
@dirrm share/ede/.ede/desktop
-@dirrm share/ede/.ede/apps
@dirrm share/ede/.ede
@dirrm share/ede