aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/enlightenment-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/enlightenment-devel/Makefile')
-rw-r--r--x11-wm/enlightenment-devel/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/x11-wm/enlightenment-devel/Makefile b/x11-wm/enlightenment-devel/Makefile
index 7cf23d2e5ed8..457533eac3cc 100644
--- a/x11-wm/enlightenment-devel/Makefile
+++ b/x11-wm/enlightenment-devel/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= enlightenment
-PORTVERSION= 0.16.3
-CATEGORIES= x11-wm gnome
+PORTVERSION= 0.16.4
+CATEGORIES= x11-wm
MASTER_SITES= ftp://ftp.enlightenment.org/pub/enlightenment/enlightenment/ \
ftp://ftp.dti.ad.jp/pub/X/enlightenment/enlightenment/ \
ftp://ftp.enlighte.nu/pub/Enlightenment/Enlightenment/ \
@@ -19,12 +19,13 @@ LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound \
Fnlib.0:${PORTSDIR}/graphics/fnlib \
Imlib.5:${PORTSDIR}/graphics/imlib \
ttf.4:${PORTSDIR}/print/freetype \
- ghttp.1:${PORTSDIR}/www/libghttp
+ ghttp.1:${PORTSDIR}/www/libghttp \
+ intl.1:${PORTSDIR}/devel/gettext
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-fsstd
+CONFIGURE_ARGS= --enable-fsstd --with-included-gettext
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -lxpg4"
@@ -32,5 +33,6 @@ MAN1= enlightenment.1
post-install:
${CHOWN} -R root:wheel ${PREFIX}/share/enlightenment/themes
+ ${CHMOD} -R a+rX ${PREFIX}/share/enlightenment/themes
.include <bsd.port.mk>