aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/enlightenment/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/enlightenment/Makefile')
-rw-r--r--x11-wm/enlightenment/Makefile61
1 files changed, 27 insertions, 34 deletions
diff --git a/x11-wm/enlightenment/Makefile b/x11-wm/enlightenment/Makefile
index 3ab016737e30..4deba354cead 100644
--- a/x11-wm/enlightenment/Makefile
+++ b/x11-wm/enlightenment/Makefile
@@ -2,62 +2,55 @@
# $FreeBSD$
PORTNAME= enlightenment
-PORTVERSION= 0.17.5
-PORTREVISION= 1
+PORTVERSION= 0.19.1
PORTEPOCH= 2
CATEGORIES= x11-wm enlightenment
-MASTER_SITES= http://download.enlightenment.org/releases/ \
- LOCAL/gblach/e17/
+MASTER_SITES= http://download.enlightenment.org/rel/apps/${PORTNAME}/
MAINTAINER= gblach@FreeBSD.org
COMMENT= Artistic X window manager
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms
+LIB_DEPENDS= libefl.so:${PORTSDIR}/devel/efl \
+ libelementary.so:${PORTSDIR}/x11-toolkits/elementary \
+ libedbus.so:${PORTSDIR}/devel/e_dbus \
+ libxcb-keysyms.so:${PORTSDIR}/x11/xcb-util-keysyms
+RUN_DEPENDS= ${LOCALBASE}/lib/evas/utils/evas_image_loader.svg:${PORTSDIR}/graphics/evas_generic_loaders-svg
-DIST_SUBDIR= e17
+DIST_SUBDIR= enlightenment
+USE_AUTOTOOLS= autoconf aclocal
GNU_CONFIGURE= yes
-USES= alias execinfo pathfix iconv gmake pkgconfig tar:bzip2
-USE_EFL= eina eet evas ecore eio edbus efreet edje \
- libtool_hack librt_hack modarch_hack
-USE_EFL_EVAS_LOADERS= eet jpeg png
-USE_EFL_EVAS_ENGINES= buffer
-USE_EFL_ECORE= ipc
+USES= alias desktop-file-utils execinfo libtool pathfix iconv gmake pkgconfig tar:xz
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
SUB_FILES= pkg-message
CONFIGURE_ARGS= --with-profile=MEDIUM_PC \
- --disable-connman
+ --disable-connman --disable-bluez4 --disable-temperature \
+ --disable-device-udev --disable-mount-udisks
-OPTIONS_DEFINE= ILLUME
-ILLUME_DESC= Enable illume module
+.include "Makefile.plist"
-.include <bsd.port.options.mk>
+DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+DOCS_CONFIGURE_ENABLE= doc
-.if ${PORT_OPTIONS:MILLUME}
-CONFIGURE_ARGS+=--enable-illume2
-PLIST_SUB+= ILLUME=""
-.else
-CONFIGURE_ARGS+=--disable-illume2
-PLIST_SUB+= ILLUME="@comment "
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
+PLIST_SUB+= NLS=""
.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|\-relname||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|\(setuid_root_mode = a=rx,u+x\)s|\1|g' \
- ${WRKSRC}/src/bin/Makefile.in
- @${REINPLACE_CMD} -e 's|@E_FM_LIBS@|@E_FM_LIBS@ -lehal -leukit|' \
- ${WRKSRC}/src/bin/e_fm/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's/\(setuid_root_mode = a=rx,u+x\)s/\1/g' \
+ ${WRKSRC}/src/bin/Makefile.mk \
+ ${WRKSRC}/src/modules/Makefile_cpufreq.mk
.if ${ARCH} == "sparc64"
BROKEN= Does not install on sparc64: signal 10