aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Makefile4
-rw-r--r--x11-wm/icewm/files/patch-src_ylocale.cc26
2 files changed, 2 insertions, 28 deletions
diff --git a/x11-wm/icewm/Makefile b/x11-wm/icewm/Makefile
index 2de436724395..7f915c3fea14 100644
--- a/x11-wm/icewm/Makefile
+++ b/x11-wm/icewm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= icewm
PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION}
@@ -12,7 +12,7 @@ COMMENT= Window Manager designed for speed, usability and consistency
LICENSE= GPLv2
-USES= gmake iconv pkgconfig
+USES= gmake iconv:translit pkgconfig
USE_XORG= ice sm x11 xext
USE_GNOME= gdkpixbuf2
GNU_CONFIGURE= yes
diff --git a/x11-wm/icewm/files/patch-src_ylocale.cc b/x11-wm/icewm/files/patch-src_ylocale.cc
deleted file mode 100644
index d76d2f4ea589..000000000000
--- a/x11-wm/icewm/files/patch-src_ylocale.cc
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/ylocale.cc.orig 2013-11-03 19:58:39.180727369 -0500
-+++ src/ylocale.cc 2013-11-03 19:58:51.540725980 -0500
-@@ -126,8 +126,12 @@ YLocale::~YLocale() {
- iconv_t YLocale::getConverter (const char *from, const char **&to) {
- iconv_t cd = (iconv_t) -1;
-
-+ char *myfrom = (char *)malloc(1 + strlen(from));
-+ strcpy(myfrom, from);
-+ char *modptr = strstr(myfrom, "//");
-+ if (NULL != modptr) *modptr = '\0';
- while (NULL != *to)
-- if ((iconv_t) -1 != (cd = iconv_open(*to, from))) return cd;
-+ if ((iconv_t) -1 != (cd = iconv_open(*to, myfrom))) return cd;
- else ++to;
-
- return (iconv_t) -1;
-@@ -149,7 +153,8 @@ YUChar *YLocale::unicodeString(const YLC
- return NULL;
-
- YUChar * uStr(new YUChar[lLen + 1]);
-- char * inbuf((char *) lStr), * outbuf((char *) uStr);
-+ const char * inbuf((char *) lStr);
-+ char * outbuf((char *) uStr);
- size_t inlen(lLen), outlen(4 * lLen);
-
- if (0 > (int) iconv(instance->toUnicode, &inbuf, &inlen, &outbuf, &outlen))