aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/metacity
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/Makefile15
-rw-r--r--x11-wm/metacity/distinfo6
-rw-r--r--x11-wm/metacity/files/patch-configure8
-rw-r--r--x11-wm/metacity/files/patch-src_core_main.c51
-rw-r--r--x11-wm/metacity/files/patch-src_core_util.c11
-rw-r--r--x11-wm/metacity/pkg-plist27
6 files changed, 44 insertions, 74 deletions
diff --git a/x11-wm/metacity/Makefile b/x11-wm/metacity/Makefile
index f81ad05c167d..115be9eea549 100644
--- a/x11-wm/metacity/Makefile
+++ b/x11-wm/metacity/Makefile
@@ -3,12 +3,11 @@
# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
#
# $FreeBSD$
-# $MCom: ports/x11-wm/metacity/Makefile,v 1.140 2008/10/08 04:21:46 marcus Exp $
+# $MCom: ports/x11-wm/metacity/Makefile,v 1.145 2009/03/26 17:34:42 marcus Exp $
#
PORTNAME= metacity
-PORTVERSION= 2.24.0
-PORTREVISION= 1
+PORTVERSION= 2.26.0
CATEGORIES= x11-wm
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,7 +15,9 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A window manager for the adult in you
+BUILD_DEPENDS= zenity:${PORTSDIR}/x11/zenity
LIB_DEPENDS= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+RUN_DEPENDS= zenity:${PORTSDIR}/x11/zenity
CONFLICTS= expocity-[0-9]*
USE_BZIP2= yes
@@ -32,7 +33,11 @@ MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
GCONF_SCHEMAS= metacity.schemas
-MAN1= metacity-theme-viewer.1 metacity-window-demo.1 \
- metacity.1
+MAN1= metacity-message.1 metacity-theme-viewer.1 \
+ metacity-window-demo.1 metacity.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-Werror||g' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/x11-wm/metacity/distinfo b/x11-wm/metacity/distinfo
index a6116af821aa..092049327eaa 100644
--- a/x11-wm/metacity/distinfo
+++ b/x11-wm/metacity/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/metacity-2.24.0.tar.bz2) = d4aa782d5f71b6c42514b239684a4aa3
-SHA256 (gnome2/metacity-2.24.0.tar.bz2) = 90eed0a36aae302db52af12220c4cf863c9cccebd233015104f2d88cb17ec076
-SIZE (gnome2/metacity-2.24.0.tar.bz2) = 2160557
+MD5 (gnome2/metacity-2.26.0.tar.bz2) = eafb624e79fbcdab6da59acc222430b1
+SHA256 (gnome2/metacity-2.26.0.tar.bz2) = 29ba16411899d963bae69a4d72d37dec38a33e62412fe769d497de4555559078
+SIZE (gnome2/metacity-2.26.0.tar.bz2) = 2289848
diff --git a/x11-wm/metacity/files/patch-configure b/x11-wm/metacity/files/patch-configure
index 155c6ecfc4a7..dc37d41d93d6 100644
--- a/x11-wm/metacity/files/patch-configure
+++ b/x11-wm/metacity/files/patch-configure
@@ -1,9 +1,9 @@
---- configure.orig 2008-09-23 00:55:36.000000000 -0400
-+++ configure 2008-09-23 00:55:52.000000000 -0400
-@@ -31530,7 +31530,7 @@ metacity-$VERSION:
+--- configure.orig 2009-03-17 18:59:17.000000000 +0100
++++ configure 2009-03-17 19:00:03.000000000 +0100
+@@ -23806,7 +23806,7 @@
"
- METACITY_MINOR_VERSION=24
+ METACITY_MINOR_VERSION=26
-if test $(( $(echo $METACITY_MINOR_VERSION) %2)) == "1"; then
+if test $(( $(echo $METACITY_MINOR_VERSION) %2)) = "1"; then
stable_version=$(( ($METACITY_MINOR_VERSION / 2) * 2))
diff --git a/x11-wm/metacity/files/patch-src_core_main.c b/x11-wm/metacity/files/patch-src_core_main.c
deleted file mode 100644
index db73c224f1bd..000000000000
--- a/x11-wm/metacity/files/patch-src_core_main.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- src/core/main.c.orig 2008-10-08 00:10:39.000000000 -0400
-+++ src/core/main.c 2008-10-08 00:18:44.000000000 -0400
-@@ -312,6 +312,23 @@ void meta_select_display (gchar *display
- /* DO NOT FREE envVar, putenv() sucks */
- putenv (envVar);
- }
-+
-+static
-+void meta_finalize (void)
-+{
-+ meta_display_close (meta_get_display (),
-+ CurrentTime); /* I doubt correct timestamps matter here */
-+
-+ meta_session_shutdown ();
-+}
-+
-+static
-+void sigterm_handler (int signum)
-+{
-+ meta_finalize ();
-+
-+ exit (meta_exit_code);
-+}
-
- /**
- * This is where the story begins. It parses commandline options and
-@@ -352,6 +369,11 @@ main (int argc, char **argv)
- g_strerror (errno));
- #endif
-
-+ act.sa_handler = &sigterm_handler;
-+ if (sigaction (SIGTERM, &act, NULL) < 0)
-+ g_printerr ("Failed to register SIGTERM handler: %s\n",
-+ g_strerror (errno));
-+
- if (g_getenv ("METACITY_VERBOSE"))
- meta_set_verbose (TRUE);
- if (g_getenv ("METACITY_DEBUG"))
-@@ -478,11 +500,8 @@ main (int argc, char **argv)
-
- g_main_loop_run (meta_main_loop);
-
-- meta_display_close (meta_get_display (),
-- CurrentTime); /* I doubt correct timestamps matter here */
-+ meta_finalize ();
-
-- meta_session_shutdown ();
--
- if (meta_restart_after_quit)
- {
- GError *err;
diff --git a/x11-wm/metacity/files/patch-src_core_util.c b/x11-wm/metacity/files/patch-src_core_util.c
deleted file mode 100644
index b1799e3516d5..000000000000
--- a/x11-wm/metacity/files/patch-src_core_util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/core/util.c.orig 2008-02-27 05:42:51.000000000 +0100
-+++ src/core/util.c 2008-03-21 21:16:14.000000000 +0100
-@@ -23,7 +23,7 @@
- */
-
- #define _GNU_SOURCE
--#define _POSIX_C_SOURCE /* for fdopen() */
-+#define _POSIX_C_SOURCE 1 /* for fdopen() */
-
- #include <config.h>
- #include "util.h"
diff --git a/x11-wm/metacity/pkg-plist b/x11-wm/metacity/pkg-plist
index 9ea1d2734b78..82b209e925f7 100644
--- a/x11-wm/metacity/pkg-plist
+++ b/x11-wm/metacity/pkg-plist
@@ -18,10 +18,12 @@ libexec/metacity-dialog
share/applications/metacity.desktop
share/gnome-control-center/keybindings/50-metacity-desktop-key.xml
share/gnome-control-center/keybindings/50-metacity-key.xml
+share/gnome/help/creating-metacity-themes/C/creating-metacity-themes.xml
share/gnome/wm-properties/metacity-wm.desktop
share/locale/am/LC_MESSAGES/metacity.mo
share/locale/ar/LC_MESSAGES/metacity.mo
share/locale/as/LC_MESSAGES/metacity.mo
+share/locale/ast/LC_MESSAGES/metacity.mo
share/locale/az/LC_MESSAGES/metacity.mo
share/locale/be/LC_MESSAGES/metacity.mo
share/locale/be@latin/LC_MESSAGES/metacity.mo
@@ -30,6 +32,7 @@ share/locale/bn/LC_MESSAGES/metacity.mo
share/locale/bn_IN/LC_MESSAGES/metacity.mo
share/locale/bs/LC_MESSAGES/metacity.mo
share/locale/ca/LC_MESSAGES/metacity.mo
+share/locale/ca@valencia/LC_MESSAGES/metacity.mo
share/locale/cs/LC_MESSAGES/metacity.mo
share/locale/cy/LC_MESSAGES/metacity.mo
share/locale/da/LC_MESSAGES/metacity.mo
@@ -47,12 +50,14 @@ share/locale/fr/LC_MESSAGES/metacity.mo
share/locale/ga/LC_MESSAGES/metacity.mo
share/locale/gl/LC_MESSAGES/metacity.mo
share/locale/gu/LC_MESSAGES/metacity.mo
+share/locale/ha/LC_MESSAGES/metacity.mo
share/locale/he/LC_MESSAGES/metacity.mo
share/locale/hi/LC_MESSAGES/metacity.mo
share/locale/hr/LC_MESSAGES/metacity.mo
share/locale/hu/LC_MESSAGES/metacity.mo
share/locale/hy/LC_MESSAGES/metacity.mo
share/locale/id/LC_MESSAGES/metacity.mo
+share/locale/ig/LC_MESSAGES/metacity.mo
share/locale/is/LC_MESSAGES/metacity.mo
share/locale/it/LC_MESSAGES/metacity.mo
share/locale/ja/LC_MESSAGES/metacity.mo
@@ -60,8 +65,10 @@ share/locale/ka/LC_MESSAGES/metacity.mo
share/locale/kn/LC_MESSAGES/metacity.mo
share/locale/ko/LC_MESSAGES/metacity.mo
share/locale/ku/LC_MESSAGES/metacity.mo
+share/locale/la/LC_MESSAGES/metacity.mo
share/locale/lt/LC_MESSAGES/metacity.mo
share/locale/lv/LC_MESSAGES/metacity.mo
+share/locale/mai/LC_MESSAGES/metacity.mo
share/locale/mg/LC_MESSAGES/metacity.mo
share/locale/mk/LC_MESSAGES/metacity.mo
share/locale/ml/LC_MESSAGES/metacity.mo
@@ -89,6 +96,7 @@ share/locale/sr/LC_MESSAGES/metacity.mo
share/locale/sr@latin/LC_MESSAGES/metacity.mo
share/locale/sv/LC_MESSAGES/metacity.mo
share/locale/ta/LC_MESSAGES/metacity.mo
+share/locale/te/LC_MESSAGES/metacity.mo
share/locale/th/LC_MESSAGES/metacity.mo
share/locale/tk/LC_MESSAGES/metacity.mo
share/locale/tr/LC_MESSAGES/metacity.mo
@@ -96,6 +104,7 @@ share/locale/uk/LC_MESSAGES/metacity.mo
share/locale/vi/LC_MESSAGES/metacity.mo
share/locale/wa/LC_MESSAGES/metacity.mo
share/locale/xh/LC_MESSAGES/metacity.mo
+share/locale/yo/LC_MESSAGES/metacity.mo
share/locale/zh_CN/LC_MESSAGES/metacity.mo
share/locale/zh_HK/LC_MESSAGES/metacity.mo
share/locale/zh_TW/LC_MESSAGES/metacity.mo
@@ -218,13 +227,19 @@ share/themes/Simple/metacity-1/minimize.png
@dirrmtry share/themes/AgingGorilla
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
+@dirrm share/gnome/help/creating-metacity-themes/C
+@dirrm share/gnome/help/creating-metacity-themes
@dirrm include/metacity-1/metacity-private
@dirrm include/metacity-1
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/yo/LC_MESSAGES
+@dirrmtry share/locale/yo
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@@ -237,15 +252,27 @@ share/themes/Simple/metacity-1/minimize.png
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/la/LC_MESSAGES
+@dirrmtry share/locale/la
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
+@dirrmtry share/locale/ig/LC_MESSAGES
+@dirrmtry share/locale/ig
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/ha/LC_MESSAGES
+@dirrmtry share/locale/ha
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/be@latin/LC_MESSAGES
@dirrmtry share/locale/be@latin
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as