aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/obmenu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/obmenu/Makefile')
-rw-r--r--x11-wm/obmenu/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/obmenu/Makefile b/x11-wm/obmenu/Makefile
new file mode 100644
index 000000000000..d34ad035339d
--- /dev/null
+++ b/x11-wm/obmenu/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: obmenu
+# Date created: 2007-12-18
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= obmenu
+PORTVERSION= 1.0
+CATEGORIES= x11-wm
+MASTER_SITES= SF
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Menu manager for Openbox supporting both static and pipe menus
+
+USE_XLIB= yes
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= obMenu
+
+PORTDOCS= README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>