aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pekwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/pekwm/Makefile')
-rw-r--r--x11-wm/pekwm/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index cb9e1e90c162..7e81b54fdb8f 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -6,29 +6,33 @@
#
PORTNAME= pekwm
-PORTVERSION= 20050515
+PORTVERSION= 20060216
CATEGORIES= x11-wm
MASTER_SITES= http://bsd-unix.org/downloads/ \
http://pekwm.org/files/
-DISTNAME= ${PORTNAME}-0.1.4pre2
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= xcas@cox.net
COMMENT= A windowmanager based on aewm++
-LIB_DEPENDS= Imlib2.3:${PORTSDIR}/graphics/imlib2 \
- Xft.2:${PORTSDIR}/x11-fonts/libXft \
- pcre.0:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_AUTOTOOLS= autoconf:259 autoheader:259 automake:19 aclocal:19
USE_BZIP2= yes
USE_GCC= 3.4
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_XPM= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shape --enable-xinerama --enable-xrandr \
- --enable-xft --enable-pcre --enable-imlib2 --disable-debug \
- --enable-menus --enable-harbour
+ --enable-xft --disable-pcre --enable-image-xpm \
+ --enable-image-jpeg --enable-image-png --disable-debug \
+ --disable-pedantic --enable-menus --enable-harbour
post-install:
@${STRIP_CMD} ${PREFIX}/bin/pekwm