aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/pekwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/pekwm/Makefile')
-rw-r--r--x11-wm/pekwm/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-wm/pekwm/Makefile b/x11-wm/pekwm/Makefile
index edf6d5c3b975..0eb72c78aba5 100644
--- a/x11-wm/pekwm/Makefile
+++ b/x11-wm/pekwm/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pekwm
-PORTVERSION= 0.1.2
+PORTVERSION= 0.1.3
CATEGORIES= x11-wm
MASTER_SITES= http://pekwm.pekdon.net/files/source/
@@ -26,6 +26,12 @@ CONFIGURE_ARGS+= --enable-xinerama
CONFIGURE_ARGS+= --enable-harbour
.endif
+.if defined(WITH_PCRE)
+CONFIGURE_ARGS+= --enable-pcre
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
pre-everything::
.if !defined(WITH_XINERAMA)
@${ECHO_CMD} "To enable xinerama support define WITH_XINERAMA"
@@ -33,6 +39,9 @@ pre-everything::
.if !defined(WITH_HARBOUR)
@${ECHO_CMD} "To enable basic DockApp support define WITH_HARBOUR"
.endif
+.if !defined(WITH_PCRE)
+ @${ECHO_CMD} "To enable pcre support define WITH_PCRE"
+.endif
MAN1= pekwm.1