aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wayfire-plugins-extra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wayfire-plugins-extra/Makefile')
-rw-r--r--x11-wm/wayfire-plugins-extra/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/x11-wm/wayfire-plugins-extra/Makefile b/x11-wm/wayfire-plugins-extra/Makefile
index 379cc9d3e200..73d629bcc016 100644
--- a/x11-wm/wayfire-plugins-extra/Makefile
+++ b/x11-wm/wayfire-plugins-extra/Makefile
@@ -1,7 +1,7 @@
PORTNAME= wayfire-plugins-extra
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-wm
MAINTAINER= jbeich@FreeBSD.org
@@ -16,9 +16,29 @@ BUILD_DEPENDS= wayland-scanner:graphics/wayland \
LIB_DEPENDS= libwf-config.so:devel/wf-config \
libwlroots.so:x11-toolkits/wlroots
-USES= compiler:c++17-lang gnome meson pkgconfig
+USES= compiler:c++17-lang gnome meson pkgconfig shebangfix
USE_GITHUB= yes
+USE_GITLAB= nodefault
USE_GNOME= cairo glibmm
GH_ACCOUNT= WayfireWM
+GH_TUPLE= damianatorrpm:wayfire-plugin_dbus_interface:c705bf1:dbus/subprojects/dbus
+GL_TUPLE= wayfireplugins:windecor:6ad31bfc10c5d39c0da7c68fa435064effad6381:windecor/subprojects/windecor
+SHEBANG_FILES= subprojects/dbus/compile-schemas.sh
+bash_CMD= ${SH}
+
+OPTIONS_DEFINE= DBUS LIBRSVG2
+OPTIONS_DEFAULT=DBUS LIBRSVG2
+OPTIONS_SUB= yes
+
+DBUS_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
+DBUS_USES= xorg
+DBUS_USE= XORG=xcb
+DBUS_MESON_TRUE= enable_dbus
+DBUS_VARS= GLIB_SCHEMAS+=org.wayland.compositor.dbus.gschema.xml
+
+LIBRSVG2_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
+LIBRSVG2_USES= xorg
+LIBRSVG2_USE= GNOME=librsvg2 XORG=pixman
+LIBRSVG2_MESON_TRUE= enable_windecor
.include <bsd.port.mk>