aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index 9ed07c3b73f6..1ea5e3fc1b3f 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.92.0
+PORTREVISION= 1
CATEGORIES= x11-wm windowmaker
MASTER_SITES= ${MASTER_SITE_WINDOWMAKER}
MASTER_SITE_SUBDIR= source/release
@@ -45,6 +46,7 @@ MAN1= geticonset.1x getstyle.1x seticons.1x setstyle.1x wdwrite.1x \
OPTIONS= XINERAMA "Enable xinerama support" off \
XKB_STATUS "XKB keyboard language status support" off \
+ WM_SINGLE_CLICK "Add single-click option to WPrefs menu" on \
WM_LINGUAS "Enable support for additional locales" off
.include <bsd.port.pre.mk>
@@ -61,6 +63,10 @@ CONFIGURE_ARGS+= --enable-xinerama
CONFIGURE_ARGS+= --enable-modelock
.endif
+.if !defined(WITHOUT_WM_SINGLE_CLICK) || defined(PACKAGE_BUILDING)
+EXTRA_PATCHES+= ${WRKSRC}/contrib/single_click.diff
+.endif
+
.if defined(WITH_WM_LINGUAS) || defined(PACKAGE_BUILDING)
LINGUAS!= ${CAT} ${FILESDIR}/LINGUAS
CONFIGURE_ENV+= LINGUAS="${LINGUAS}"