aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wmfs/Makefile')
-rw-r--r--x11-wm/wmfs/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/x11-wm/wmfs/Makefile b/x11-wm/wmfs/Makefile
index 5deb841ad51a..d8c6d076867f 100644
--- a/x11-wm/wmfs/Makefile
+++ b/x11-wm/wmfs/Makefile
@@ -5,8 +5,7 @@ PORTNAME= wmfs
DISTVERSION= 201104
PORTREVISION= 4
CATEGORIES= x11-wm
-MASTER_SITES= http://wmfs.info/attachments/download/45/ \
- http://cloud.github.com/downloads/xorg62/wmfs/
+MASTER_SITES= GHC
MAINTAINER= ports@FreeBSD.org
COMMENT= Floating and tiling Window Manager From Scratch
@@ -16,23 +15,28 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+USE_GITHUB= yes
+GH_ACCOUNT= xorg62
+
USES= pkgconfig
USE_XORG= x11 xft xpm
HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX} \
+ --man-prefix ${MANPREFIX}/man \
+ --xdg-config-dir ${PREFIX}/etc/xdg
+
+CFLAGS+= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/freetype2
SUB_FILES= pkg-message
-OPTIONS_DEFINE= XRANDR XINERAMA IMLIB
+OPTIONS_DEFINE= XRANDR XINERAMA IMLIB
OPTIONS_DEFAULT= XRANDR XINERAMA IMLIB
-CONFIGURE_ARGS= --prefix ${PREFIX} \
- --man-prefix ${MANPREFIX}/man \
- --xdg-config-dir ${PREFIX}/etc/xdg
-
-XRANDR_USE= XORG=xrandr
-XRANDR_CONFIGURE_WITH+= xrandr
-XINERAMA_USE= XORG=xinerama
-XINERARAM_CONFIGURE_WITH= xinerama
+XRANDR_USE= XORG=xrandr
+XRANDR_CONFIGURE_WITH= xrandr
+XINERAMA_USE= XORG=xinerama
+XINERAMA_CONFIGURE_WITH= xinerama
IMLIB_LIB_DEPENDS= libImlib2.so:${PORTSDIR}/graphics/imlib2
IMLIB_CONFIGURE_WITH= imlib2