aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/wmii-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/wmii-devel/Makefile')
-rw-r--r--x11-wm/wmii-devel/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/x11-wm/wmii-devel/Makefile b/x11-wm/wmii-devel/Makefile
deleted file mode 100644
index 9c195faecf1b..000000000000
--- a/x11-wm/wmii-devel/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# New ports collection makefile for: Window Manager Improved 2
-# Date created: 02 Jun 2005
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= wmii
-DISTVERSION= 2
-PORTREVISION= 1
-CATEGORIES= x11-wm
-MASTER_SITES= http://wmii.de/download/
-
-MAINTAINER= danfe@FreeBSD.org
-COMMENT= The next generation of WMI window manager
-
-USE_REINPLACE= yes
-USE_X_PREFIX= yes
-
-MAKE_ARGS= PREFIX="${PREFIX}" X11DIR="${X11BASE}" CC="${CC}" \
- MANPREFIX="${PREFIX}/man"
-
-OPTIONS= CAIRO "Enable Cairo rendering backend" off \
- STRL "Use strlcpy()/strlcat() functions" off
-
-MAN1= wmibar.1 wmifs.1 wmii.1 wmikeys.1 wmimenu.1 wmir.1
-MAN5= wmii.rc.5
-
-.include <bsd.port.pre.mk>
-
-# The cairo backend is not recommended in production use, because the cairo
-# library is still very buggy and causes crashes often.
-.if defined(WITH_CAIRO)
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
-MAKE_ARGS+= DRAW=cairo
-.endif
-
-.if defined(WITH_STRL)
-MAKE_ARGS+= STRLCPY="strlcpy" STRLCAT="strlcat"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|' \
- -e 's|/usr/lib|${LOCALBASE}/lib|' \
- -e 's|-O0 -g -Wall -pedantic|${CFLAGS}|; s|-g||' \
- ${WRKSRC}/config.mk
-.if defined(WITH_CAIRO)
- @${REINPLACE_CMD} -e 's,^#CAIRO,CAIRO,' ${WRKSRC}/config.mk
-.endif
-
-.include <bsd.port.post.mk>