aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-desktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xfce4-desktop/Makefile')
-rw-r--r--x11-wm/xfce4-desktop/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 4905a0f84050..2bb5374d2a20 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfce4-desktop
PORTVERSION= 4.0.0
+PORTREVISION= 1
CATEGORIES= x11-wm xfce
MASTER_SITES= http://www.xfce.org/archive/xfce-${PORTVERSION}/src/ \
http://linux.imp.mx/xfce4/xfce_${PORTVERSION}/src/
@@ -17,14 +18,19 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 desktop background manager and root menu
BUILD_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
xfce4util.1:${PORTSDIR}/x11/libxfce4util \
xfcegui4.1:${PORTSDIR}/x11-toolkits/libxfce4gui
RUN_DEPENDS= xfce-mcs-manager:${PORTSDIR}/sysutils/xfce4-mcs-manager
USE_GNOME= gtk20
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CFLAGS=-I${LOCALBASE}/include \
+ CPPFLAGS=-I${LOCALBASE}/include \
+ LIBS=-L${LOCALBASE}/lib
.include <bsd.port.mk>