aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/xfce4-panel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xfce4-panel/Makefile')
-rw-r--r--x11-wm/xfce4-panel/Makefile29
1 files changed, 24 insertions, 5 deletions
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index dfe602b3dc28..e2f8bff8b437 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -6,29 +6,36 @@
#
PORTNAME= xfce4-panel
-PORTVERSION= 4.6.3
-PORTREVISION= 3
+PORTVERSION= 4.6.4
CATEGORIES= x11-wm xfce
-MASTER_SITES= http://archive.xfce.org/src/xfce/xfce4-panel/4.6/
+MASTER_SITES= ${MASTER_SITE_XFCE}
DIST_SUBDIR= xfce4
MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 panel module
-LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck
+LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck \
+ cairo.2:${PORTSDIR}/graphics/cairo
CONFLICTS= xfce4-systray-*
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget gtk20 intltool intlhack pkgconfig
USE_LDCONFIG= yes
+USE_PERL5= yes
USE_XFCE= configenv libexo libgui libutil
+USE_XORG= x11 sm
+
+CONFIGURE_ARGS= --enable-gtk-doc-html=no \
+ --disable-debug
OPTIONS= GTKDOC "install the library documentation" off \
- STARTUP "Enable startup notification support" on
+ STARTUP "Enable startup notification support" on \
+ NLS "Enable Native Language Support" on
.include <bsd.port.pre.mk>
@@ -48,4 +55,16 @@ CONFIGURE_ARGS+=--enable-startup-notification
CONFIGURE_ARGS+=--disable-startup-notification
.endif
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| manual||g' ${WRKSRC}/docs/Makefile.in
+
.include <bsd.port.post.mk>