aboutsummaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/herbstluftwm/Makefile14
-rw-r--r--x11-wm/herbstluftwm/distinfo6
-rw-r--r--x11-wm/herbstluftwm/files/patch-CMakeLists.txt7
-rw-r--r--x11-wm/herbstluftwm/pkg-plist1
4 files changed, 16 insertions, 12 deletions
diff --git a/x11-wm/herbstluftwm/Makefile b/x11-wm/herbstluftwm/Makefile
index af93e11b118f..9e9de532fb12 100644
--- a/x11-wm/herbstluftwm/Makefile
+++ b/x11-wm/herbstluftwm/Makefile
@@ -2,7 +2,7 @@
PORTNAME= herbstluftwm
DISTVERSIONPREFIX= v
-DISTVERSION= 0.9.1
+DISTVERSION= 0.9.2
CATEGORIES= x11-wm
MAINTAINER= uzsolt@uzsolt.hu
@@ -11,20 +11,24 @@ COMMENT= Manual tiling window manager for X11
LICENSE= BSD2CLAUSE
BUILD_DEPENDS= asciidoc:textproc/asciidoc
+LIB_DEPENDS+= libfreetype.so:print/freetype2
-USES= cmake compiler:c++11-lang gnome pkgconfig shebangfix xorg
+USES= cmake compiler:c++11-lang gnome \
+ localbase:ldflags pkgconfig shebangfix xorg
USE_GITHUB= yes
USE_GNOME= glib20
-USE_XORG= x11 xext xinerama xrandr
+USE_XORG= x11 xext xft xinerama xrandr
SHEBANG_FILES= doc/gendoc.py scripts/*.sh share/*.sh
+SUB_FILES= pkg-message
+
OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_SUB= yes
DOCS_USES+= python:3.5+,build
DOCS_CMAKE_BOOL+= WITH_DOCUMENTATION
-OPTIONS_SUB= yes
-SUB_FILES= pkg-message
+DOCS_VARS= binary_alias=python3=${PYTHON_CMD}
.include <bsd.port.options.mk>
diff --git a/x11-wm/herbstluftwm/distinfo b/x11-wm/herbstluftwm/distinfo
index f948795381c2..fa6300836fa4 100644
--- a/x11-wm/herbstluftwm/distinfo
+++ b/x11-wm/herbstluftwm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1609227561
-SHA256 (herbstluftwm-herbstluftwm-v0.9.1_GH0.tar.gz) = 91014db4a6411fd1bb6cff55a2b952b9ac88cbcd9c11db504b69f814c317b5b0
-SIZE (herbstluftwm-herbstluftwm-v0.9.1_GH0.tar.gz) = 364218
+TIMESTAMP = 1613566681
+SHA256 (herbstluftwm-herbstluftwm-v0.9.2_GH0.tar.gz) = 0f9cca8dd5215a8682692fe98608926090597ca578012950932ef785fd52d188
+SIZE (herbstluftwm-herbstluftwm-v0.9.2_GH0.tar.gz) = 377875
diff --git a/x11-wm/herbstluftwm/files/patch-CMakeLists.txt b/x11-wm/herbstluftwm/files/patch-CMakeLists.txt
index baf6199023c3..ac1cef86b9cc 100644
--- a/x11-wm/herbstluftwm/files/patch-CMakeLists.txt
+++ b/x11-wm/herbstluftwm/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2020-04-20 22:03:58 UTC
+--- CMakeLists.txt.orig 2021-02-17 10:06:29 UTC
+++ CMakeLists.txt
@@ -20,13 +20,13 @@ include(ccache)
@@ -28,8 +28,9 @@
@@ -47,7 +47,6 @@ add_subdirectory(share)
## install everything that was not installed from subdirectories
- install(FILES BUGS NEWS DESTINATION ${DOCDIR})
+ install(FILES NEWS DESTINATION ${DOCDIR})
-install(FILES LICENSE DESTINATION ${LICENSEDIR})
- install(DIRECTORY scripts/ DESTINATION ${DOCDIR}/examples USE_SOURCE_PERMISSIONS)
+-install(DIRECTORY scripts/ DESTINATION ${DOCDIR}/examples USE_SOURCE_PERMISSIONS)
++install(DIRECTORY scripts/ DESTINATION /usr/local/share/examples/herbstluftwm USE_SOURCE_PERMISSIONS)
# vim: et:ts=4:sw=4
diff --git a/x11-wm/herbstluftwm/pkg-plist b/x11-wm/herbstluftwm/pkg-plist
index daad50dfa35f..5382434eb3d8 100644
--- a/x11-wm/herbstluftwm/pkg-plist
+++ b/x11-wm/herbstluftwm/pkg-plist
@@ -11,7 +11,6 @@ share/zsh/site-functions/_herbstclient
%%PORTDOCS%%man/man1/herbstclient.1.gz
%%PORTDOCS%%man/man1/herbstluftwm.1.gz
%%PORTDOCS%%man/man7/herbstluftwm-tutorial.7.gz
-%%PORTDOCS%%%%DOCSDIR%%/BUGS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/herbstclient.html
%%PORTDOCS%%%%DOCSDIR%%/herbstluftwm-tutorial.html