aboutsummaryrefslogtreecommitdiff
path: root/x11/XFree86-4-libraries/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/XFree86-4-libraries/Makefile')
-rw-r--r--x11/XFree86-4-libraries/Makefile63
1 files changed, 51 insertions, 12 deletions
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index efa8999eb623..72d32403376c 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -6,34 +6,70 @@
#
PORTNAME= libraries
-PORTVERSION= 4.0.1
-PORTREVISION= 2
+PORTVERSION= 4.0.3
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XFREE}
MASTER_SITE_SUBDIR= ${PORTVERSION}
PKGNAMEPREFIX= XFree86-
-DISTFILES= X401src-1.tgz
+DISTFILES= X402src-1.tgz
+
+PATCH_SITES= ${MASTER_SITE_XFREE:S,%SUBDIR%/source,4.0.3/patches,g}
+PATCHFILES= 4.0.2-4.0.3.diff.gz
+PATCH_DIST_STRIP= -p1
MAINTAINER= taguchi@tohoku.iij.ad.jp
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
+RUN_DEPENDS= mkhtmlindex:${PORTSDIR}/devel/imake-4
XFREE86_VERSION= 4
-XFREE86_HTML_MAN= yes
PREFIX?= ${X11BASE}
+MANCOMPRESSED= yes
+XFREE86_HTML_MAN= yes
MTREE_FILE= /etc/mtree/BSD.x11-4.dist
INSTALLS_SHLIB= yes
DIST_SUBDIR= xc
WRKSRC= ${WRKDIR}/xc
-SCRIPTS_ENV+= PREFIX=${PREFIX} \
- X11BASE=${X11BASE} \
- WRKDIR=${WRKDIR} \
- DISTDIR=${DISTDIR}
+SCRIPTS_ENV= HasXdmAuth=${HasXdmAuth} \
+ HasSecureRPC=${HasSecureRPC} \
+ BuildPexExt=${BuildPexExt} \
+ BuildXinerama=${BuildXinerama} \
+ BuildXIE=${BuildXIE} \
+ BuildAoutLibraries=${BuildAoutLibraries} \
+ ForceNormalLib=${ForceNormalLib} \
+ DebuggableLibraries=${DebuggableLibraries}
+MAKE_ENV= PKGNAMEPREFIX=${PKGNAMEPREFIX} \
+ PORTNAME=${PORTNAME} \
+ PORTVERSION=${PORTVERSION}
ALL_TARGET= FreeBSDPortsBuild
INSTALL_TARGET= FreeBSDPortsInstall FreeBSDPortsInstall.man installXlib
-MANCOMPRESSED= yes
MAN1= libxrx.1
-MAN3= Xaw.3
+MAN3= Xaw.3 Xft.3
+
+# XFree86 User Config:
+# ---
+# Name Default Meaning
+# ----------------------------------------------------------------------------
+# HasXdmAuth YES support XDM-AUTHORIZATION-1.
+# HasSecureRPC YES build with SecureRPC (require FreeBSD-3 or later)
+# BuildPexExt YES build PEX extension
+# BuildXinerama YES build Xinerama extension
+# BuildXIE YES build XIE extension
+# BuildAoutLibraries NO build with old Aout libs.
+# ForceNormalLib YES build with static libs.
+# DebuggableLibraries NO build with debug libs (require FreeBSD-4 or later)
+# ----------------------------------------------------------------------------
+# DEFAULT means ports will use values which set by ${PORTSDIR}/devel/imake-4
+#
+HasXdmAuth?= DEFAULT
+HasSecureRPC?= DEFAULT
+BuildPexExt?= DEFAULT
+BuildXinerama?= DEFAULT
+BuildXIE?= DEFAULT
+BuildAoutLibraries?= DEFAULT
+ForceNormalLib?= DEFAULT
+DebuggableLibraries?= DEFAULT
+# End of XFree86 User Config
.include <bsd.port.pre.mk>
@@ -44,7 +80,7 @@ PLIST_SUB+= OSMESA:="@comment "
PLIST_SUB+= OSMESA:=""
.endif
-.if defined(XDM_DES)
+.if ${HasXdmAuth} == DEFAULT || ${HasXdmAuth} == YES
.if ${USA_RESIDENT} == YES
pre-fetch:
@${ECHO}
@@ -53,10 +89,13 @@ pre-fetch:
MASTER_SITES+= ftp://psych.psy.uq.oz.au/pub/X11R5/ \
ftp://ftp.internat.freebsd.org/pub/FreeBSD/X11-Crypto/ \
ftp://ftp3.za.freebsd.org/pub/FreeBSD/X11-Crypto/
-EXTRACT_ONLY= X401src-1.tgz
+EXTRACT_ONLY= X402src-1.tgz
DISTFILES+= Wraphelp.c
IGNOREFILES= Wraphelp.c
.endif
.endif
+do-configure:
+ cd ${.CURDIR} && ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure
+
.include <bsd.port.post.mk>