aboutsummaryrefslogtreecommitdiff
path: root/x11/dzen2/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11/dzen2/files')
-rw-r--r--x11/dzen2/files/patch-Makefile25
-rw-r--r--x11/dzen2/files/patch-config.mk4
-rw-r--r--x11/dzen2/files/patch-gadgets__config.mk9
-rw-r--r--x11/dzen2/files/patch-gadgets__kittscanner.sh17
4 files changed, 53 insertions, 2 deletions
diff --git a/x11/dzen2/files/patch-Makefile b/x11/dzen2/files/patch-Makefile
new file mode 100644
index 000000000000..9094a2ce55bd
--- /dev/null
+++ b/x11/dzen2/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- ./Makefile.orig 2007-08-18 08:18:50.000000000 +0200
++++ ./Makefile 2014-06-17 14:58:37.000000000 +0200
+@@ -27,6 +27,9 @@
+ @strip $@
+ @echo "Run ./help for documentation"
+
++gadgets:
++ $(MAKE) -C gadgets
++
+ clean:
+ @echo cleaning
+ @rm -f dzen2 ${OBJ} dzen2-${VERSION}.tar.gz
+@@ -49,8 +52,11 @@
+ @cp -f dzen2 ${DESTDIR}${PREFIX}/bin
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/dzen2
+
++install-gadgets: gadgets
++ $(MAKE) -C gadgets install
++
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+ @rm -f ${DESTDIR}${PREFIX}/bin/dzen2
+
+-.PHONY: all options clean dist install uninstall
++.PHONY: all options clean dist install uninstall gadgets install-gadgets
diff --git a/x11/dzen2/files/patch-config.mk b/x11/dzen2/files/patch-config.mk
index 88734290dd81..0704cc7993fe 100644
--- a/x11/dzen2/files/patch-config.mk
+++ b/x11/dzen2/files/patch-config.mk
@@ -1,5 +1,5 @@
---- config.mk.orig 2013-07-03 22:32:45.866885213 +0200
-+++ config.mk 2013-07-03 22:32:51.306100406 +0200
+--- ./config.mk.orig 2007-08-18 08:18:50.000000000 +0200
++++ ./config.mk 2014-06-17 14:58:37.000000000 +0200
@@ -49,5 +49,5 @@
#LDFLAGS = -g ${LIBS}
diff --git a/x11/dzen2/files/patch-gadgets__config.mk b/x11/dzen2/files/patch-gadgets__config.mk
new file mode 100644
index 000000000000..459377efe292
--- /dev/null
+++ b/x11/dzen2/files/patch-gadgets__config.mk
@@ -0,0 +1,9 @@
+--- ./gadgets/config.mk.orig 2007-08-18 08:18:50.000000000 +0200
++++ ./gadgets/config.mk 2014-06-17 14:58:37.000000000 +0200
+@@ -14,5 +14,5 @@
+ LDFLAGS = ${LIBS}
+
+ # compiler and linker
+-CC = gcc
++CC ?= cc
+ LD = ${CC}
diff --git a/x11/dzen2/files/patch-gadgets__kittscanner.sh b/x11/dzen2/files/patch-gadgets__kittscanner.sh
new file mode 100644
index 000000000000..6f53699f2f34
--- /dev/null
+++ b/x11/dzen2/files/patch-gadgets__kittscanner.sh
@@ -0,0 +1,17 @@
+--- ./gadgets/kittscanner.sh.orig 2014-06-17 15:00:13.000000000 +0200
++++ ./gadgets/kittscanner.sh 2014-06-17 15:00:24.000000000 +0200
+@@ -19,10 +19,10 @@
+
+ SLEEP=0.1
+
+-#DZEN=/usr/local/bin/dzen2
+-DZEN=../dzen2
+-#DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR"
+-DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR -xs 1 -y 30"
++DZEN=/usr/local/bin/dzen2
++#DZEN=../dzen2
++DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR"
++#DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR -xs 1 -y 30"
+
+ #-----------------------------------------------------------------------
+