aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-calendar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/e17-module-calendar/Makefile')
-rw-r--r--x11/e17-module-calendar/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/x11/e17-module-calendar/Makefile b/x11/e17-module-calendar/Makefile
index a0c387313007..96735db318aa 100644
--- a/x11/e17-module-calendar/Makefile
+++ b/x11/e17-module-calendar/Makefile
@@ -6,27 +6,28 @@
#
PORTNAME= calendar
-PORTVERSION= 23062006
-PORTREVISION= 2
+PORTVERSION= 20060926
+PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= x11
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
PKGNAMEPREFIX= e17-module-
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Nice calendar module for e17
-BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= ecore evas edje eet
+USE_EFL_ESMART= trans_x11
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
+IGNORE= doesn't compile with recent e17
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -36,4 +37,10 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e s,`${PRINTF} '\r'`,,g ${WRKSRC}/src/*.[ch]
+
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>