aboutsummaryrefslogtreecommitdiff
path: root/x11/e17-module-screenshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/e17-module-screenshot/Makefile')
-rw-r--r--x11/e17-module-screenshot/Makefile35
1 files changed, 7 insertions, 28 deletions
diff --git a/x11/e17-module-screenshot/Makefile b/x11/e17-module-screenshot/Makefile
index 405edd0fda9f..1639edacaedd 100644
--- a/x11/e17-module-screenshot/Makefile
+++ b/x11/e17-module-screenshot/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= screenshot
-PORTVERSION= 20070223
-PORTREVISION= 1
+PORTVERSION= 20080223
+PORTREVISION= 0
CATEGORIES= x11
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
PKGNAMEPREFIX= e17-module-
@@ -16,8 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= An e17 module which allows users to take screenshots
-BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
-RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel \
+ emprint:${PORTSDIR}/x11/emprint
+RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel \
+ emprint:${PORTSDIR}/x11/emprint
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -25,27 +27,4 @@ USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_EFL= edje
-OPTIONS= IMAGIC "Use ImageMagick" on \
- SCROT "Use Scrot" off
-
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_IMAGIC)
-BUILD_DEPENDS+= import:${PORTSDIR}/graphics/ImageMagick
-RUN_DEPENDS+= import:${PORTSDIR}/graphics/ImageMagick
-.endif
-
-.if defined(WITH_SCROT)
-BUILD_DEPENDS+= scrot:${PORTSDIR}/graphics/scrot
-RUN_DEPENDS+= scrot:${PORTSDIR}/graphics/scrot
-.endif
-
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>