aboutsummaryrefslogtreecommitdiff
path: root/x11/ebuttons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ebuttons/Makefile')
-rw-r--r--x11/ebuttons/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/x11/ebuttons/Makefile b/x11/ebuttons/Makefile
deleted file mode 100644
index 5335624b9400..000000000000
--- a/x11/ebuttons/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: E-Buttons
-# Date created: 30 March 2000
-# Whom: jhb
-#
-# $FreeBSD$
-#
-
-PORTNAME= E-buttons
-PORTVERSION= 0.2
-PORTREVISION= 11
-CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://people.freebsd.org/~gahr/distfiles/
-MASTER_SITE_SUBDIR= gahr
-
-MAINTAINER= gahr@FreeBSD.org
-COMMENT= A simple epplet that contains several buttons used to launch programs
-
-DEPRECATED= Website has disappeared
-EXPIRATION_DATE=2011-09-03
-
-LIB_DEPENDS= epplet.3:${PORTSDIR}/x11-wm/epplets
-
-PLIST_FILES= bin/E-Buttons.epplet
-
-WRKSRC= ${WRKDIR}/E-buttons
-
-USE_GL= gl
-USE_EFL= imlib2
-
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -lepplet -lGL -lImlib2 ${PTHREAD_LIBS}
-
-do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o E-Buttons.epplet \
- ${PORTNAME}.c ${LDFLAGS}
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/E-Buttons.epplet ${PREFIX}/bin
-
-.include <bsd.port.mk>