aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-imf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ecore-imf/Makefile')
-rw-r--r--x11/ecore-imf/Makefile37
1 files changed, 16 insertions, 21 deletions
diff --git a/x11/ecore-imf/Makefile b/x11/ecore-imf/Makefile
index 032b932ebd9f..e209233c5697 100644
--- a/x11/ecore-imf/Makefile
+++ b/x11/ecore-imf/Makefile
@@ -6,45 +6,40 @@
#
PORTNAME= imf
-PORTVERSION= 0.9.9.042
-PORTREVISION= 0
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (IMF module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS= --enable-ecore-con \
- --enable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --enable-ecore-imf \
- --disable-ecore-imf_evas
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-con \
+ --enable-ecore-config \
+ --enable-ecore-imf
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E \
-e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/\.libs,${LOCALBASE}/lib,'\
-e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/libecore_con\.la,-lecore_con,'\
${BUILD_WRKSRC}/Makefile.in
post-install: