aboutsummaryrefslogtreecommitdiff
path: root/x11/ecore-input_evas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/ecore-input_evas/Makefile')
-rw-r--r--x11/ecore-input_evas/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11/ecore-input_evas/Makefile b/x11/ecore-input_evas/Makefile
new file mode 100644
index 000000000000..cd26db8d7d18
--- /dev/null
+++ b/x11/ecore-input_evas/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ecore-input_evas
+# Date created: 14 June 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= input_evas
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Enlightenment core abstraction library (evas input module)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore evas libtool_hack
+USE_EFL_ECORE= input
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input_evas
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-input \
+ --enable-ecore-input_evas
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/libecore_input\.la,-lecore_input,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-input-evas.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>