aboutsummaryrefslogtreecommitdiff
path: root/x11/eterm
diff options
context:
space:
mode:
Diffstat (limited to 'x11/eterm')
-rw-r--r--x11/eterm/Makefile2
-rw-r--r--x11/eterm/files/patch-src_command.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/x11/eterm/Makefile b/x11/eterm/Makefile
index 8a9afb91a57f..3046390fa875 100644
--- a/x11/eterm/Makefile
+++ b/x11/eterm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= eterm
PORTVERSION= 0.9.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= x11
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Eterm-${PORTVERSION}
DISTNAME= Eterm-${PORTVERSION}
diff --git a/x11/eterm/files/patch-src_command.c b/x11/eterm/files/patch-src_command.c
new file mode 100644
index 000000000000..cdd5ec336243
--- /dev/null
+++ b/x11/eterm/files/patch-src_command.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/command.c.orig
++++ src/command.c
+@@ -1561,7 +1561,7 @@
+ * child processes remain alive upon deletion of the window.
+ */
+ {
+- unsigned short i;
++ unsigned long i;
+ unsigned long max_fds;
+
+ /* get number of available file descriptors */