aboutsummaryrefslogtreecommitdiff
path: root/x11/fbdesk
diff options
context:
space:
mode:
Diffstat (limited to 'x11/fbdesk')
-rw-r--r--x11/fbdesk/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/x11/fbdesk/Makefile b/x11/fbdesk/Makefile
index aaf58e00c30f..bb2f979e86f3 100644
--- a/x11/fbdesk/Makefile
+++ b/x11/fbdesk/Makefile
@@ -20,6 +20,8 @@ PLIST_FILES= bin/fbdesk
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+PORTDOCS= COPYING ChangeLog INSTALL README
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000
@@ -29,4 +31,12 @@ post-patch:
${WRKSRC}/src/FbTk/Timer.hh
.endif
+post-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.post.mk>