aboutsummaryrefslogtreecommitdiff
path: root/x11/gdkxft/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gdkxft/Makefile')
-rw-r--r--x11/gdkxft/Makefile17
1 files changed, 4 insertions, 13 deletions
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index 5be4bf93eac4..27ae7bd199f7 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gdkxft
PORTVERSION= 1.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= x11
MASTER_SITES= SF
@@ -18,25 +18,16 @@ LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
-WANT_GNOME= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnuregex -liconv" \
CFLAGS="${CFLAGS} `pkg-config xft --cflags`"
-CONFIGURE_ARGS= --sbindir=${PREFIX}/bin
+CONFIGURE_ARGS= --sbindir=${PREFIX}/bin \
+ --without-gnome
USE_LDCONFIG= yes
MAN8= gdkxft_sysinstall.8
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mlibglade}!="" && ${HAVE_GNOME:Mlibcapplet}!=""
-USE_GNOME+= gnomeprefix libglade libcapplet
-PKGNAMESUFFIX= -gnome
-.else
-CONFIGURE_ARGS+= --without-gnome
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|gtk-config --prefix|$$GTK_CONFIG --prefix|g ; \
s|libgdk.la|libgdk-12.so|g ; \
@@ -58,4 +49,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>