aboutsummaryrefslogtreecommitdiff
path: root/x11/gdm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gdm/Makefile')
-rw-r--r--x11/gdm/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index dfadb4c668f0..69a41b9c4bcd 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gdm
PORTVERSION= 2.30.5
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -43,7 +44,8 @@ USE_GNOME= gnomehack intlhack gnomehier gconf2 librsvg2 \
gnomedocutils gnomeprefix gnomepanel
GCONF_SCHEMAS= gdm-simple-greeter.schemas
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-working-directory=${PREFIX}/etc/gdm/home
+CONFIGURE_ARGS= --with-working-directory=${PREFIX}/etc/gdm/home \
+ --with-at-spi-registryd-directory=${LOCALBASE}/libexec
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAS_SA_LEN" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-lm" \
@@ -64,7 +66,7 @@ OPTIONS= IPV6 "Enable IPv6 support" off \
.if defined(WITHOUT_KEYRING)
SUB_LIST+= PAM_KEYRING=\#
.else
-RUN_DEPENDS+= ${LOCALBASE}/lib/pam_gnome_keyring.so:${PORTSDIR}/security/gnome-keyring
+LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
SUB_LIST+= PAM_KEYRING=
.endif