aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 885b47ad9e7b..0745ce4215d0 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -3,12 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-applets/Makefile,v 1.152 2007/03/12 17:47:04 marcus Exp $
+# $MCom: ports/x11/gnome-applets/Makefile,v 1.165 2007/09/16 17:19:03 ahze Exp $
#
PORTNAME= gnome-applets
-PORTVERSION= 2.18.0
-PORTREVISION= 4
+PORTVERSION= 2.20.0
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -45,8 +44,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
OS_SYS="/usr/include"
GCONF_SCHEMAS= charpick.schemas drivemount.schemas geyes.schemas \
- gswitchit.schemas gweather.schemas \
- mixer.schemas multiload.schemas \
+ gweather.schemas mixer.schemas multiload.schemas \
stickynotes.schemas
OPTIONS= MINI_COMMANDER "Enable mini-commander applet" off
@@ -99,8 +97,8 @@ PLIST_SUB+= PYTHON="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|g' \
${WRKSRC}/libgweather/weather-met.c
- @${REINPLACE_CMD} -e 's|system-tools-backends|system-tools-backends-2.0|g' \
- ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|" == "|" = "|g'
.if !defined(USE_PYTHON)
@${REINPLACE_CMD} -e 's|HAVE_PYGTK="yes"|HAVE_PYGTK="no"|' \
${WRKSRC}/configure