aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-applets/Makefile')
-rw-r--r--x11/gnome-applets/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
deleted file mode 100644
index a15e0b692fe3..000000000000
--- a/x11/gnome-applets/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: gnomeapplets2
-# Date created: 26th May 2000
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomeapplets2
-PORTVERSION= 1.102.1
-PORTREVISION= 1
-CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
-DISTNAME= gnome-applets-${PORTVERSION}
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-
-LIB_DEPENDS= panel-applet-2.0:${PORTSDIR}/x11/gnomepanel \
- gailutil.13:${PORTSDIR}/x11-toolkits/gail \
- gtop-2.0:${PORTSDIR}/devel/libgtop2
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(prefix\)/lib/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
- s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
-
-.include <bsd.port.mk>