aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-applets/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-applets/files')
-rw-r--r--x11/gnome-applets/files/patch-aa30
-rw-r--r--x11/gnome-applets/files/patch-battstat_Makefile.in27
-rw-r--r--x11/gnome-applets/files/patch-multiload::linux-proc.c84
-rw-r--r--x11/gnome-applets/files/patch-stickynotes_Makefile.in11
-rw-r--r--x11/gnome-applets/files/patch-wireless_wireless-applet.c39
5 files changed, 30 insertions, 161 deletions
diff --git a/x11/gnome-applets/files/patch-aa b/x11/gnome-applets/files/patch-aa
index 6638e387efc9..73b0823ce82e 100644
--- a/x11/gnome-applets/files/patch-aa
+++ b/x11/gnome-applets/files/patch-aa
@@ -1,14 +1,6 @@
---- configure.orig Mon Sep 8 20:00:28 2003
-+++ configure Wed Sep 24 23:29:28 2003
-@@ -8250,6 +8250,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -11792,6 +11793,7 @@
+--- configure.orig Sun Feb 22 19:22:49 2004
++++ configure Sun Feb 22 19:24:33 2004
+@@ -22912,6 +22912,7 @@
*irix*) CDROM_HOST=irix; CDROM_LIBS="-lcdaudio -lmediad -lds";cd_device_path="/dev/cdrom";;
*linux*) CDROM_HOST=linux;cd_device_path="/dev/cdrom";;
*netbsd*) CDROM_HOST=netbsd;cd_device_path="/dev/rcd0";;
@@ -16,16 +8,16 @@
*solaris*) CDROM_HOST=solaris;cd_device_path="/vol/dev/aliases/cdrom0";cdplayer_type_sun=true;;
esac
case "$host" in
-@@ -11856,7 +11858,7 @@
+@@ -23034,7 +23035,7 @@
;;
- # list of supported OS cores
-- *-*-linux*|*-*-freebsd*|*-*-openbsd*)
-+ *-*-linux*|i386-*-freebsd*|*-*-openbsd*)
- echo "$as_me:$LINENO: checking for apm_read in -lapm" >&5
- echo $ECHO_N "checking for apm_read in -lapm... $ECHO_C" >&6
- if test "${ac_cv_lib_apm_apm_read+set}" = set; then
-@@ -13646,14 +13648,14 @@
+ # list of supported OS cores that do not use libapm
+- *-*-freebsd*|*-*-netbsd*|*-*-openbsd*)
++ i386-*-freebsd*|*-*-netbsd*|*-*-openbsd*)
+ ;;
+ *)
+ echo "warning: ${host} is not supported by battstat_applet, not building" >&2
+@@ -24905,14 +24906,14 @@
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
cat >>confdefs.h <<_ACEOF
diff --git a/x11/gnome-applets/files/patch-battstat_Makefile.in b/x11/gnome-applets/files/patch-battstat_Makefile.in
deleted file mode 100644
index 6ddfc03c3b07..000000000000
--- a/x11/gnome-applets/files/patch-battstat_Makefile.in
+++ /dev/null
@@ -1,27 +0,0 @@
---- battstat/Makefile.in.orig Tue Sep 23 00:11:20 2003
-+++ battstat/Makefile.in Tue Sep 23 00:14:03 2003
-@@ -154,11 +154,11 @@
- pixmapsdir = $(datadir)/pixmaps
- pixmaps_DATA = battstat.png
- @HAVE_LIBAPM_TRUE@APMLIB = @HAVE_LIBAPM_TRUE@-lapm
--@HAVE_LIBAPM_FALSE@APMLIB = @HAVE_LIBAPM_FALSE@apmlib/libapm.a
-+@HAVE_LIBAPM_FALSE@APMLIB =
- @HAVE_LIBAPM_TRUE@APMDIR =
--@HAVE_LIBAPM_FALSE@APMDIR = @HAVE_LIBAPM_FALSE@apmlib
-+@HAVE_LIBAPM_FALSE@APMDIR =
- @HAVE_LIBAPM_TRUE@APMINC =
--@HAVE_LIBAPM_FALSE@APMINC = @HAVE_LIBAPM_FALSE@-Iapmlib/
-+@HAVE_LIBAPM_FALSE@APMINC =
-
- SUBDIRS = docs sounds $(APMDIR)
-
-@@ -230,8 +230,7 @@
- @HAVE_LIBAPM_TRUE@battstat_applet_2_DEPENDENCIES = \
- @HAVE_LIBAPM_TRUE@$(top_builddir)/screen-exec/libscreen-exec.la
- @HAVE_LIBAPM_FALSE@battstat_applet_2_DEPENDENCIES = \
--@HAVE_LIBAPM_FALSE@$(top_builddir)/screen-exec/libscreen-exec.la \
--@HAVE_LIBAPM_FALSE@apmlib/libapm.a
-+@HAVE_LIBAPM_FALSE@$(top_builddir)/screen-exec/libscreen-exec.la
- battstat_applet_2_LDFLAGS =
- CFLAGS = @CFLAGS@
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
diff --git a/x11/gnome-applets/files/patch-multiload::linux-proc.c b/x11/gnome-applets/files/patch-multiload::linux-proc.c
deleted file mode 100644
index 9eb916f2b59f..000000000000
--- a/x11/gnome-applets/files/patch-multiload::linux-proc.c
+++ /dev/null
@@ -1,84 +0,0 @@
---- multiload/linux-proc.c.orig Thu Jul 10 04:26:58 2003
-+++ multiload/linux-proc.c Mon Nov 17 23:54:38 2003
-@@ -5,12 +5,17 @@
- #include <fcntl.h>
- #include <unistd.h>
- #include <assert.h>
-+#ifdef __FreeBSD__
-+#include <sys/socket.h>
-+#include <net/if.h>
-+#endif
-
- #include <glibtop.h>
- #include <glibtop/cpu.h>
- #include <glibtop/mem.h>
- #include <glibtop/swap.h>
- #include <glibtop/loadavg.h>
-+#include <glibtop/netload.h>
-
- #include "linux-proc.h"
-
-@@ -33,6 +38,10 @@
- static unsigned needed_loadavg_flags =
- (1 << GLIBTOP_LOADAVG_LOADAVG);
-
-+static unsigned needed_netload_flags =
-+(1 << GLIBTOP_NETLOAD_IF_FLAGS) +
-+(1 << GLIBTOP_NETLOAD_BYTES_TOTAL);
-+
- void
- GetLoad (int Maximum, int data [4], LoadGraph *g)
- {
-@@ -236,6 +245,44 @@
- int delta[COUNT_TYPES], i;
- static int ticks = 0;
- static gulong past[COUNT_TYPES] = {0};
-+#ifdef __FreeBSD__
-+ struct if_nameindex *ifindex, *ifptr;
-+ static int max = 500;
-+
-+ ifindex = if_nameindex();
-+ if (!ifindex)
-+ return;
-+
-+ memset(present, 0, sizeof (present));
-+
-+ for (ifptr = ifindex; ifptr->if_index && ifptr->if_name; ifptr++)
-+ {
-+ int index;
-+ glibtop_netload netload;
-+
-+ glibtop_get_netload(&netload, ifptr->if_name);
-+ if (!netload.flags)
-+ continue;
-+
-+ assert ((netload.flags & needed_netload_flags) == needed_netload_flags);
-+
-+ if (!(netload.if_flags & (1L << GLIBTOP_IF_FLAGS_UP)))
-+ continue;
-+ if (netload.if_flags & (1L << GLIBTOP_IF_FLAGS_LOOPBACK))
-+ continue;
-+
-+ if (netload.if_flags & (1L << GLIBTOP_IF_FLAGS_POINTOPOINT)) {
-+ index = strncmp(ifptr->if_name, "sl", 2) ? PPP_COUNT : SLIP_COUNT;
-+ } else {
-+ index = ETH_COUNT;
-+ }
-+
-+ present[index] += netload.bytes_total;
-+ }
-+
-+ if_freenameindex(ifindex);
-+
-+#else
- static char *netdevfmt = NULL;
- char *cp, buffer[256];
- FILE *fp;
-@@ -317,6 +364,7 @@
- }
-
- fclose(fp);
-+#endif
-
- for (i = 0; i < 5; i++)
- data[i] = 0;
diff --git a/x11/gnome-applets/files/patch-stickynotes_Makefile.in b/x11/gnome-applets/files/patch-stickynotes_Makefile.in
deleted file mode 100644
index 973b7e342c3e..000000000000
--- a/x11/gnome-applets/files/patch-stickynotes_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- stickynotes/Makefile.in.orig Thu Aug 28 01:00:09 2003
-+++ stickynotes/Makefile.in Thu Aug 28 01:00:26 2003
-@@ -142,7 +142,7 @@
-
- SUBDIRS = pixmaps docs
-
--CFLAGS = -Wall -g
-+CFLAGS += -Wall -g
-
- INCLUDES = -I. -I$(srcdir) $(GNOME_APPLETS_CFLAGS) $(LIBGLADE_CFLAGS) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DSTICKYNOTES_GLADEDIR=\"$(gladedir)\" -DSTICKYNOTES_ICONDIR=\"$(icondir)\"
-
diff --git a/x11/gnome-applets/files/patch-wireless_wireless-applet.c b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
index 1f1af0974a9d..650c4694ad35 100644
--- a/x11/gnome-applets/files/patch-wireless_wireless-applet.c
+++ b/x11/gnome-applets/files/patch-wireless_wireless-applet.c
@@ -1,5 +1,5 @@
---- wireless/wireless-applet.c.orig Mon Oct 27 15:52:14 2003
-+++ wireless/wireless-applet.c Fri Jan 16 16:47:14 2004
+--- wireless/wireless-applet.c.orig Tue Oct 21 19:06:53 2003
++++ wireless/wireless-applet.c Sat Jan 3 19:26:43 2004
@@ -30,6 +30,15 @@
#include <math.h>
#include <dirent.h>
@@ -72,7 +72,7 @@
wireless_applet_draw (applet, percent);
}
-@@ -235,22 +260,180 @@
+@@ -235,22 +260,179 @@
}
}
@@ -116,7 +116,7 @@
+static void
+get_wi_data (WirelessApplet *applet, char *device, long int *level)
+{
-+ struct wi_req wreq;
++ struct wi_req wreq;
+ long int signal_strength;
+
+ bzero((char *)&wreq, sizeof(wreq));
@@ -156,9 +156,9 @@
+
+ if (ioctl(s, SIOCGAIRONET, &ifr) == -1) {
+ gtk_tooltips_set_tip (applet->tips,
-+ GTK_WIDGET (applet),
-+ "ioctl Error",
-+ NULL);
++ GTK_WIDGET (applet),
++ "ioctl Error",
++ NULL);
+ return 0;
+ }
+
@@ -169,7 +169,7 @@
+static void
+get_an_data (WirelessApplet *applet, char *device, long int *level)
+{
-+ struct an_req areq;
++ struct an_req areq;
+ struct an_ltv_status *sts;
+#ifdef AN_RID_RSSI_MAP
+ struct an_ltv_rssi_map an_rssimap;
@@ -192,13 +192,13 @@
+#ifdef AN_RID_RSSI_MAP
+ if (rssimap_valid)
+ signal_strength = (long int)(an_rssimap.an_entries[
-+ sts->an_normalized_strength].an_rss_pct);
++ sts->an_normalized_strength].an_rss_pct);
+ else
+ signal_strength = (long int)(sts->an_normalized_strength);
+#else
+ signal_strength = (long int)(sts->an_normalized_rssi);
+#endif
-+
++
+ memcpy(level, &signal_strength, sizeof(level));
+}
+#endif
@@ -230,14 +230,14 @@
/* Here we begin to suck... */
do {
+#ifdef __FreeBSD__
-+ if (ifs == NULL || ifs->if_name == NULL) {
++ if (ifs == NULL || ifs->if_name == NULL) {
+ break;
+ }
-+ strlcpy(device, ifs->if_name, 6);
++ strlcpy(device, ifs->if_name, 6);
+ if (g_strncasecmp(device, "an", 2)==0) {
+ applet->devices = g_list_prepend (applet->devices, g_strdup (device));
+ if (g_strcasecmp(applet->device, device)==0) {
-+ get_an_data(applet, device, &level);
++ get_an_data(applet, device, &level);
+ wireless_applet_update_state (applet, device, 0, level, 0);
+ }
+ }
@@ -245,17 +245,16 @@
+ if (g_strncasecmp(device, "wi", 2)==0 || g_strncasecmp(device, "ath", 3)==0) {
+ applet->devices = g_list_prepend (applet->devices, g_strdup (device));
+ if (g_strcasecmp(applet->device, device)==0) {
-+ get_wi_data(applet, device, &level);
++ get_wi_data(applet, device, &level);
+ wireless_applet_update_state (applet, device, 0, level, 0);
+ }
+ }
+ ifs++;
+#else
-+
char *ptr;
fgets (line, 256, applet->file);
-@@ -283,6 +466,7 @@
+@@ -283,6 +465,7 @@
wireless_applet_update_state (applet, device, link, level, noise);
}
}
@@ -263,7 +262,7 @@
} while (1);
if (g_list_length (applet->devices)==1) {
-@@ -294,17 +478,23 @@
+@@ -294,17 +477,23 @@
}
/* rewind the /proc/net/wireless file */
@@ -287,7 +286,7 @@
wireless_applet_read_device_state (applet);
-@@ -351,6 +541,7 @@
+@@ -351,6 +540,7 @@
static void
start_file_read (WirelessApplet *applet)
{
@@ -295,7 +294,7 @@
applet->file = fopen ("/proc/net/wireless", "rt");
if (applet->file == NULL) {
gtk_tooltips_set_tip (applet->tips,
-@@ -359,6 +550,7 @@
+@@ -359,6 +549,7 @@
NULL);
show_error_dialog (_("There doesn't seem to be any wireless devices configured on your system.\nPlease verify your configuration if you think this is incorrect."));
}
@@ -303,7 +302,7 @@
}
static void
-@@ -646,8 +838,10 @@
+@@ -646,8 +837,10 @@
applet->prefs = NULL;
}