aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-menus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-menus/Makefile')
-rw-r--r--x11/gnome-menus/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 2fedf2fd9275..6b8656e952ed 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -3,33 +3,26 @@
# $MCom: ports/trunk/x11/gnome-menus/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= gnome-menus
-PORTVERSION= 3.13.3
-PORTREVISION= 1
+PORTVERSION= 3.36.0
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Implementation of the FreeDesktop Desktop Menu Spec
-USES= gettext gmake gnome libtool pathfix pkgconfig python tar:xz
+LICENSE= GPLv2
+
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig python tar:xz
USE_GNOME= glib20 gnomeprefix intlhack \
introspection:build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-post-patch:
- @${SED} -e 's|/usr/local|${LOCALBASE}|g' \
- < ${FILESDIR}/KDE.directory > ${WRKSRC}/KDE.directory
-
post-install:
@${MKDIR} -p ${STAGEDIR}${PREFIX}/etc/xdg/menus/
@${INSTALL_DATA} ${WRKSRC}/layout/gnome-applications.menu \
${STAGEDIR}${PREFIX}/etc/xdg/menus/gnome-applications.menu
- @${INSTALL_DATA} ${WRKSRC}/KDE.directory \
- ${STAGEDIR}${PREFIX}/share/desktop-directories
.include <bsd.port.mk>