aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-screensaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-screensaver/Makefile')
-rw-r--r--x11/gnome-screensaver/Makefile36
1 files changed, 18 insertions, 18 deletions
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 20ac6e499dfc..efc70f133bde 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -3,37 +3,42 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.36 2006/04/13 07:52:40 bland Exp $
+# $MCom: ports/x11/gnome-screensaver/Makefile,v 1.58 2006/10/07 19:45:39 marcus Exp $
#
PORTNAME= gnome-screensaver
-PORTVERSION= 2.14.3
+PORTVERSION= 2.16.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME screen saver and locker
-LIB_DEPENDS= dbus-1.2:${PORTSDIR}/devel/dbus
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= xscreensaver-gl-helper:${PORTSDIR}/x11/xscreensaver-gnome-hacks
USE_BZIP2= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gnomemenus
-CONFIGURE_ARGS= --with-gdm-config=${X11BASE}/etc/gdm/custom.conf \
+CONFIGURE_ARGS= --with-gdm-config=${LOCALBASE}/etc/gdm/custom.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \
- --with-xscreensaverhackdir=${X11BASE}/bin/xscreensaver-hacks
+ --with-xscreensaverhackdir=${LOCALBASE}/bin/xscreensaver-hacks
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-
GCONF_SCHEMAS= gnome-screensaver.schemas
PLIST= ${WRKDIR}/pkg-plist
-XSCREENSAVER_DIR= ${X11BASE}/share/xscreensaver/config
+XSCREENSAVER_DIR= ${LOCALBASE}/share/xscreensaver/config
+SCREENSAVER_DIR= share/gnome/applications/screensavers
+
+XSCREENSAVER_EXCLUDE= "(popsquares.xml)"
OPTIONS= PAM "Pluggable Authentication Module support" off
@@ -47,25 +52,20 @@ BROKEN= Does not build on 4.X
CONFIGURE_ARGS+= --disable-pam
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
- ${WRKSRC}/configure
-
pre-install:
@${CP} ${.CURDIR}/pkg-plist ${PLIST}
@cd ${XSCREENSAVER_DIR} && ${FIND} -s * -maxdepth 1 -type f -name "*.xml" | \
- ${SED} -e 's:^:share/gnome/gnome-screensaver/themes/xscreensaver/:' | \
+ ${GREP} -Ev ${XSCREENSAVER_EXCLUDE} | \
+ ${SED} -e 's:^:${SCREENSAVER_DIR}/:' | \
${SED} -e 's:[.]xml$$:.desktop:' >> ${PLIST}
- @${ECHO_CMD} @dirrm share/gnome/gnome-screensaver/themes/xscreensaver >> ${PLIST}
- @${ECHO_CMD} @dirrm share/gnome/gnome-screensaver/themes >> ${PLIST}
- @${ECHO_CMD} @dirrm share/gnome/gnome-screensaver >> ${PLIST}
+ @${ECHO_CMD} @dirrm ${SCREENSAVER_DIR} >> ${PLIST}
post-install:
${CHOWN} root ${PREFIX}/libexec/gnome-screensaver-dialog
${CHMOD} +s ${PREFIX}/libexec/gnome-screensaver-dialog
- ${MKDIR} ${PREFIX}/share/gnome/gnome-screensaver/themes/xscreensaver
- cd ${PREFIX}/share/gnome/gnome-screensaver/themes/xscreensaver && \
+ cd ${PREFIX}/${SCREENSAVER_DIR} && \
${FIND} -s ${XSCREENSAVER_DIR} -maxdepth 1 -type f -name "*.xml" | \
+ ${GREP} -Ev ${XSCREENSAVER_EXCLUDE} | \
${XARGS} ${WRKSRC}/data/migrate-xscreensaver-config.sh
.include <bsd.port.post.mk>