aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-session/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-session/Makefile')
-rw-r--r--x11/gnome-session/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/x11/gnome-session/Makefile b/x11/gnome-session/Makefile
deleted file mode 100644
index 302733eb2cbb..000000000000
--- a/x11/gnome-session/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-# New ports collection makefile for: gnomesession
-# Date created: 08 May 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnomesession
-PORTVERSION= 1.5.19
-CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta5
-DISTNAME= gnome-session-${PORTVERSION}
-DIST_SUBDIR= gnome2
-
-MAINTAINER= gnome@FreeBSD.org
-
-LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-
-MAN1= gnome-libice-check.1 gnome-login-check.1 gnome-session.1 \
- gnome-smproxy.1 gnome-wm.1 save-session.1 session-properties.1
-MAN5= default.session.5
-
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-.include <bsd.port.mk>