aboutsummaryrefslogtreecommitdiff
path: root/x11/gnome-swallow/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome-swallow/Makefile')
-rw-r--r--x11/gnome-swallow/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/gnome-swallow/Makefile b/x11/gnome-swallow/Makefile
index e40d26b4d61b..79fdeb2e5a50 100644
--- a/x11/gnome-swallow/Makefile
+++ b/x11/gnome-swallow/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-swallow
PORTVERSION= 1.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 gnome
MASTER_SITES= http://interreality.org/~tetron/technology/swallow/
@@ -18,8 +18,9 @@ USE_XORG= x11
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomepanel
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="`pkg-config --libs libgnomeui-2.0`"
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \