aboutsummaryrefslogtreecommitdiff
path: root/x11/gnomepanel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnomepanel/Makefile')
-rw-r--r--x11/gnomepanel/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11/gnomepanel/Makefile b/x11/gnomepanel/Makefile
new file mode 100644
index 000000000000..b95bd8fafd6f
--- /dev/null
+++ b/x11/gnomepanel/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: gnomepanel
+# Date created: 27 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomepanel
+PORTVERSION= 1.5.19
+CATEGORIES= x11 gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-20020501
+DISTNAME= gnome-panel-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= wnck-1.2:${PORTSDIR}/x11-toolkits/libwnck \
+ gnome-desktop-2.0:${PORTSDIR}/x11/gnomedesktop
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --disable-gtk-doc \
+ --with-kde-datadir=${LOCALBASE}/share \
+ --with-kde-docdir=${LOCALBASE}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+MAN1= gnome-panel-2.1 gnome-panel-properties.1
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>