aboutsummaryrefslogtreecommitdiff
path: root/x11/gromit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gromit/Makefile')
-rw-r--r--x11/gromit/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/x11/gromit/Makefile b/x11/gromit/Makefile
index 7ee75d5568aa..5e420ffcd162 100644
--- a/x11/gromit/Makefile
+++ b/x11/gromit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gromit
-PORTVERSION= 20011210
-PORTREVISION= 1
+PORTVERSION= 20041213
CATEGORIES= x11
MASTER_SITES= http://www.home.unix-ag.org/simon/gromit/
@@ -15,10 +14,16 @@ MAINTAINER= sergei@FreeBSD.org
COMMENT= "GRaphics Over Miscellaneous Objects (Gromit)"
USE_X_PREFIX= yes
-USE_GNOME= gtk12
+USE_REINPLACE= yes
+USE_GNOME= gtk20
DOCS= AUTHORS ChangeLog README
+post-extract:
+ @${REINPLACE_CMD} -e 's|gcc|$${CC}|' \
+ -e 's|`gtk-config|$${CFLAGS} `pkg-config gtk\+-2.0|' \
+ ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gromit ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}