aboutsummaryrefslogtreecommitdiff
path: root/x11/kde4
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kde4')
-rw-r--r--x11/kde4/Makefile.kde8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
index fe30441d54e0..702ba2e09519 100644
--- a/x11/kde4/Makefile.kde
+++ b/x11/kde4/Makefile.kde
@@ -17,6 +17,14 @@ _NO_KDE_FINAL= yes
_NO_KDE_NDEBUG= yes
DISTNAME= ${PORTNAME}-${PKGNAMEPREFIX:S/-$//}-${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PKGNAMEPREFIX:S/-$//}
+
+# nasty hack to force newer timestamps on cache
+# required to enable correct building
+.if !target(post-extract)
+post-extract:
+ @${FIND} ${WRKDIR} -type f -name index.cache.bz2 \
+ | ${XARGS} -n 10 -x ${TOUCH}
+.endif
.endif
# KDE_DIST_VERSION (PORTVERSION)