aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4-runtime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4-runtime/Makefile')
-rw-r--r--x11/kdebase4-runtime/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 68e1930996f0..25caa1fa04ff 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -8,7 +8,6 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 4
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
@@ -37,6 +36,7 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+DO_NOT_COMPILE= nsplugins
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--without-java \
--with-qt-dir=${X11BASE} \
@@ -47,6 +47,10 @@ OPTIONS= ARTSWRAPPER "Suid wrapper for aRts, req'd for realtime prio" on
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
+.if defined(DO_NOT_COMPILE)
+CONFIGURE_ENV+=DO_NOT_COMPILE="${DO_NOT_COMPILE}"
+.endif # defined(DO_NOT_COMPILE)
+
.if !defined(WITHOUT_ARTSWRAPPER)
RUN_DEPENDS+= artswrapper:${PORTSDIR}/audio/artswrapper
.endif