aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4-runtime')
-rw-r--r--x11/kdebase4-runtime/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index fa24519d655a..fbc50933f025 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -41,27 +41,20 @@ CONFIGURE_ARGS+=--without-java \
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.pre.mk>
-.if exists(${X11BASE}/include/Xm/Xm.h)
-WITH_MOTIF= yes
-.endif # exists(${X11BASE}/include/Xm/Xm.h)
-
.if defined(WITHOUT_MOTIF)
-.undef WITH_MOTIF
CONFIGURE_ARGS+= --without-motif
-.endif # defined(WITHOUT_MOTIF)
-
-.if defined(WITH_MOTIF)
+.else
USE_MOTIF= yes
PLIST_APPEND+= plist.motif
-.else
+
pre-extract::
@${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
+ @${ECHO_MSG} "If you want to compile WITHOUT Motif support, hit"
+ @${ECHO_MSG} "Ctrl-C right now and use \"make WITHOUT_MOTIF=yes\""
@${ECHO_MSG}
- @${ECHO_MSG} "Motif is used for Netscape plugin compatibility."
+ @${ECHO_MSG} "This will DISABLE netscape plugin compatibility."
@${ECHO_MSG}
-.endif # defined(WITH_MOTIF)
+.endif # defined(WITHOUT_MOTIF)
post-extract:
@${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv