aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4-workspace
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4-workspace')
-rw-r--r--x11/kdebase4-workspace/Makefile11
-rw-r--r--x11/kdebase4-workspace/distinfo4
-rw-r--r--x11/kdebase4-workspace/files/patch-khotkeys__libkhotkeysprivate__CMakeLists.txt9
-rw-r--r--x11/kdebase4-workspace/files/pkg-message.in10
-rw-r--r--x11/kdebase4-workspace/pkg-plist1
5 files changed, 15 insertions, 20 deletions
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 55b6d2edd17d..02f198187678 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -42,10 +42,11 @@ RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
${KDE4_PREFIX}/lib/kde4/libexec/polkit-kde-authentication-agent-1:${PORTSDIR}/sysutils/polkit-kde \
${KDE4_PREFIX}/bin/nepomukcontroller:${PORTSDIR}/misc/nepomukcontroller
-SUB_FILES= kdm layout.js
+SUB_FILES= kdm layout.js pkg-message
USE_RC_SUBR= kdm4
USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4 oxygen
KDE4_BUILDENV= yes
+USE_GMAKE= yes
USE_BZIP2= yes
USE_QT_VER= 4
QT_COMPONENTS= assistant corelib dbus designer gui network opengl \
@@ -65,10 +66,8 @@ CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DWITH_NetworkManager:BOOL=OFF \
-DWITH_Xmms:BOOL=OFF \
-DWITH_Googlegadgets:BOOL=OFF \
- -DWITH_QEdje:BOOL=OFF \
-DWITH_PyKDE4:BOOL=OFF
#PyKDE4, Xmms and Googlegadgets could be enabled,
-#QEdje has not been ported yet.
OPTIONS= PLASMA_PYTHON "Support for plasmoids written in Python" off \
PLASMA_RUBY "Support for plasmoids written in Ruby" off
@@ -92,9 +91,6 @@ LIB_DEPENDS+= utempter:${PORTSDIR}/sysutils/libutempter
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/lib/X11,${LOCALBASE}/lib/X11,g' \
- -e 's,/usr/share/X11,${LOCALBASE}/share/X11,g' \
- ${PATCH_WRKSRC}/kcontrol/keyboard/xkb_rules.cpp
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
${PATCH_WRKSRC}/startkde.cmake \
${PATCH_WRKSRC}/kcontrol/kfontinst/lib/KfiConstants.h \
@@ -103,8 +99,6 @@ post-patch:
${PATCH_WRKSRC}/kdm/backend/client.c \
${PATCH_WRKSRC}/kdm/kfrontend/genkdmconf.c \
${PATCH_WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's,resolv,c,g' \
- ${PATCH_WRKSRC}/cmake/modules/FindPCIUTILS.cmake
pre-configure:
${REINPLACE_CMD} -e '/ksysguardd/ d' \
@@ -124,5 +118,6 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/layout.js ${PREFIX}/share/apps/plasma/layout-templates/org.kde.freebsd.defaultWallpaper/contents
cd ${WRKDIR}/stripes-freebsd-1.0 && \
${COPYTREE_SHARE} . ${PREFIX}/share/wallpapers
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/x11/kdebase4-workspace/distinfo b/x11/kdebase4-workspace/distinfo
index 2b54b9aa4f8a..d47a4c30c331 100644
--- a/x11/kdebase4-workspace/distinfo
+++ b/x11/kdebase4-workspace/distinfo
@@ -1,4 +1,4 @@
-SHA256 (KDE/kdebase-workspace-4.6.2.tar.bz2) = 6a55a53282a0ec7dd61f16f87fb8d0097d945891504982eb5122c96238b711e1
-SIZE (KDE/kdebase-workspace-4.6.2.tar.bz2) = 69356153
+SHA256 (KDE/kdebase-workspace-4.6.3.tar.bz2) = ab11dbfc48b94a4cb867436d91aa80a3677bdb6e49a6df8cc1c70a4f8dd5868d
+SIZE (KDE/kdebase-workspace-4.6.3.tar.bz2) = 69349331
SHA256 (KDE/stripes-freebsd-1.0.tar.bz2) = 6ac543c0be09df2ef89061740f4e6f8d5b807462d030dbbc3bcfd58056431127
SIZE (KDE/stripes-freebsd-1.0.tar.bz2) = 4258348
diff --git a/x11/kdebase4-workspace/files/patch-khotkeys__libkhotkeysprivate__CMakeLists.txt b/x11/kdebase4-workspace/files/patch-khotkeys__libkhotkeysprivate__CMakeLists.txt
deleted file mode 100644
index 72261776035d..000000000000
--- a/x11/kdebase4-workspace/files/patch-khotkeys__libkhotkeysprivate__CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
---- ./khotkeys/libkhotkeysprivate/CMakeLists.txt.orig 2010-12-02 10:16:38.017500408 +1000
-+++ ./khotkeys/libkhotkeysprivate/CMakeLists.txt 2010-12-02 10:16:45.839492868 +1000
-@@ -75,5 +75,5 @@
- target_link_libraries(khotkeysprivate ${X11_XTest_LIB})
- endif(X11_XTest_FOUND)
- set_target_properties(khotkeysprivate PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION})
--install(TARGETS khotkeysprivate ${INSTALL_TARGETS_DEFAULT_ARGS} LIBRARY NAMELINK_SKIP)
-+install(TARGETS khotkeysprivate ${INSTALL_TARGETS_DEFAULT_ARGS})
-
diff --git a/x11/kdebase4-workspace/files/pkg-message.in b/x11/kdebase4-workspace/files/pkg-message.in
new file mode 100644
index 000000000000..d48b4affeea0
--- /dev/null
+++ b/x11/kdebase4-workspace/files/pkg-message.in
@@ -0,0 +1,10 @@
+=====================================================================
+
+To enable KDE Display Manager (KDM), add the following lines
+to /etc/rc.conf:
+local_startup="${local_startup} %%PREFIX%%/etc/rc.d"
+kdm4_enable="YES"
+
+You also need procfs to be mounted. See man procfs for details.
+
+=====================================================================
diff --git a/x11/kdebase4-workspace/pkg-plist b/x11/kdebase4-workspace/pkg-plist
index 4d23a847675c..2a2aaf5bad76 100644
--- a/x11/kdebase4-workspace/pkg-plist
+++ b/x11/kdebase4-workspace/pkg-plist
@@ -399,7 +399,6 @@ lib/libkfontinst.so.5.0.1
lib/libkfontinstui.so
lib/libkfontinstui.so.5
lib/libkfontinstui.so.5.0.1
-lib/libkhotkeysprivate.so
lib/libkhotkeysprivate.so.5
lib/libkhotkeysprivate.so.5.0.1
lib/libkickoff.so