aboutsummaryrefslogtreecommitdiff
path: root/x11/kdebase4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdebase4/Makefile')
-rw-r--r--x11/kdebase4/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 3e2388979c98..9c4478fed378 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdebase
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -82,5 +83,11 @@ post-configure:
post-install:
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
+.for file in kdmrc
+.if !exists(${PREFIX}/share/config/kdm/${file})
+ @${CP} ${PREFIX}/share/config/kdm/${file}.dist \
+ ${PREFIX}/share/config/kdm/${file}
+.endif
+.endfor
.include <bsd.port.post.mk>