aboutsummaryrefslogtreecommitdiff
path: root/x11/kdelibs4/files
diff options
context:
space:
mode:
Diffstat (limited to 'x11/kdelibs4/files')
-rw-r--r--x11/kdelibs4/files/patch-KDE4Defaults.cmake10
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_PythonMacros.cmake63
-rw-r--r--x11/kdelibs4/files/patch-git76e0376d16
-rw-r--r--x11/kdelibs4/files/patch-git_e405fa9153
-rw-r--r--x11/kdelibs4/files/patch-kdecore__CMakeLists.txt11
-rw-r--r--x11/kdelibs4/files/patch-kparts__componentfactory.h29
-rw-r--r--x11/kdelibs4/files/patch-mimetypes_kde.xml19
7 files changed, 50 insertions, 251 deletions
diff --git a/x11/kdelibs4/files/patch-KDE4Defaults.cmake b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
index e53d2e53da57..8255113b68bc 100644
--- a/x11/kdelibs4/files/patch-KDE4Defaults.cmake
+++ b/x11/kdelibs4/files/patch-KDE4Defaults.cmake
@@ -1,16 +1,16 @@
---- ./cmake/modules/KDE4Defaults.cmake.orig 2009-05-10 10:28:06.000000000 +0200
-+++ ./cmake/modules/KDE4Defaults.cmake 2009-05-10 10:29:00.000000000 +0200
-@@ -25,12 +25,12 @@
+--- ./cmake/modules/KDE4Defaults.cmake.orig 2012-11-01 23:08:00.000000000 +0000
++++ ./cmake/modules/KDE4Defaults.cmake 2012-11-02 15:05:55.862878877 +0000
+@@ -21,12 +21,12 @@
# define the generic version of the libraries here
# this makes it easy to advance it when the next KDE release comes
# Use this version number for libraries which are at version n in KDE version n
--set(GENERIC_LIB_VERSION "4.8.0")
+-set(GENERIC_LIB_VERSION "4.9.5")
-set(GENERIC_LIB_SOVERSION "4")
+set(GENERIC_LIB_VERSION "5.0.1")
+set(GENERIC_LIB_SOVERSION "5")
# Use this version number for libraries which are already at version n+1 in KDE version n
--set(KDE_NON_GENERIC_LIB_VERSION "5.8.0")
+-set(KDE_NON_GENERIC_LIB_VERSION "5.9.5")
-set(KDE_NON_GENERIC_LIB_SOVERSION "5")
+set(KDE_NON_GENERIC_LIB_VERSION "7.0.1")
+set(KDE_NON_GENERIC_LIB_SOVERSION "7")
diff --git a/x11/kdelibs4/files/patch-cmake_modules_PythonMacros.cmake b/x11/kdelibs4/files/patch-cmake_modules_PythonMacros.cmake
index 2bcfcbadd752..5ef1320f261e 100644
--- a/x11/kdelibs4/files/patch-cmake_modules_PythonMacros.cmake
+++ b/x11/kdelibs4/files/patch-cmake_modules_PythonMacros.cmake
@@ -1,30 +1,39 @@
---- ./cmake/modules/PythonMacros.cmake.orig 2011-03-10 07:44:37.000000000 -0500
-+++ ./cmake/modules/PythonMacros.cmake 2011-03-10 07:46:14.000000000 -0500
-@@ -35,6 +35,7 @@
+--- ./cmake/modules/PythonMacros.cmake.orig 2012-11-30 07:17:39.000000000 +0000
++++ ./cmake/modules/PythonMacros.cmake 2013-01-03 16:30:53.706219657 +0000
+@@ -41,8 +41,10 @@
+ # To get the right version for suffix
+ STRING(REPLACE "." "" _suffix ${PYTHON_SHORT_VERSION})
+ SET(_bin_pyc ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/__pycache__/${_filenamebase}.cpython-${_suffix}.pyc)
++ SET(_bin_pyo ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/__pycache__/${_filenamebase}.cpython-${_suffix}.pyo)
+ ELSE(PYTHON_SHORT_VERSION GREATER 3.1)
+ SET(_bin_pyc ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyc)
++ SET(_bin_pyo ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyo)
+ ENDIF(PYTHON_SHORT_VERSION GREATER 3.1)
- SET(_bin_py ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filename})
- SET(_bin_pyc ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyc)
-+ SET(_bin_pyo ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyo)
+ FILE(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${_basepath})
+@@ -55,6 +57,7 @@
+ TARGET compile_python_files
+ COMMAND ${CMAKE_COMMAND} -E echo ${_message}
+ COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
++ COMMAND ${PYTHON_EXECUTABLE} -O ${_python_compile_py} ${_bin_py}
+ DEPENDS ${_absfilename}
+ )
+ ELSE(_abs_bin_py STREQUAL ${_absfilename})
+@@ -63,14 +66,15 @@
+ COMMAND ${CMAKE_COMMAND} -E echo ${_message}
+ COMMAND ${CMAKE_COMMAND} -E copy ${_absfilename} ${_bin_py}
+ COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
++ COMMAND ${PYTHON_EXECUTABLE} -O ${_python_compile_py} ${_bin_py}
+ DEPENDS ${_absfilename}
+ )
+ ENDIF(_abs_bin_py STREQUAL ${_absfilename})
- FILE(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${_basepath})
+ IF(PYTHON_SHORT_VERSION GREATER 3.1)
+- INSTALL(FILES ${_bin_pyc} DESTINATION ${DESTINATION_DIR}/__pycache__/)
++ INSTALL(FILES ${_bin_pyc} ${_bin_pyo} DESTINATION ${DESTINATION_DIR}/__pycache__/)
+ ELSE (PYTHON_SHORT_VERSION GREATER 3.1)
+- INSTALL(FILES ${_bin_pyc} DESTINATION ${DESTINATION_DIR})
++ INSTALL(FILES ${_bin_pyc} ${_bin_pyo} DESTINATION ${DESTINATION_DIR})
+ ENDIF (PYTHON_SHORT_VERSION GREATER 3.1)
+ ENDIF("$ENV{PYTHONDONTWRITEBYTECODE}" STREQUAL "")
-@@ -46,6 +47,7 @@
- TARGET compile_python_files
- COMMAND ${CMAKE_COMMAND} -E echo ${message}
- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-+ COMMAND ${PYTHON_EXECUTABLE} -O ${_python_compile_py} ${_bin_py}
- DEPENDS ${_absfilename}
- )
- ELSE(_abs_bin_py STREQUAL ${_absfilename})
-@@ -54,9 +56,10 @@
- COMMAND ${CMAKE_COMMAND} -E echo ${message}
- COMMAND ${CMAKE_COMMAND} -E copy ${_absfilename} ${_bin_py}
- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-+ COMMAND ${PYTHON_EXECUTABLE} -O ${_python_compile_py} ${_bin_py}
- DEPENDS ${_absfilename}
- )
- ENDIF(_abs_bin_py STREQUAL ${_absfilename})
-
-- INSTALL(FILES ${_bin_pyc} DESTINATION ${DESINATION_DIR})
-+ INSTALL(FILES ${_bin_pyc} ${_bin_pyo} DESTINATION ${DESINATION_DIR})
- ENDMACRO(PYTHON_INSTALL)
diff --git a/x11/kdelibs4/files/patch-git76e0376d b/x11/kdelibs4/files/patch-git76e0376d
deleted file mode 100644
index f22d569d9399..000000000000
--- a/x11/kdelibs4/files/patch-git76e0376d
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/nepomuk/core/nepomukmainmodel.cpp b/nepomuk/core/nepomukmainmodel.cpp
-index 8dc0b1f..be23b38 100644
---- nepomuk/core/nepomukmainmodel.cpp
-+++ nepomuk/core/nepomukmainmodel.cpp
-@@ -94,10 +94,9 @@ public:
-
- // we may get disconnected from the server but we don't want to try
- // to connect every time the model is requested
-- if ( forced || (!m_socketConnectFailed && !localSocketClient.isConnected()) ) {
-+ if ( !m_socketConnectFailed && !localSocketClient.isConnected() ) {
- delete localSocketModel;
- localSocketModel = 0;
-- localSocketClient.disconnect();
- QString socketName = KGlobal::dirs()->locateLocal( "socket", "nepomuk-socket" );
- kDebug() << "Connecting to local socket" << socketName;
- if ( localSocketClient.connect( socketName ) ) {
diff --git a/x11/kdelibs4/files/patch-git_e405fa9 b/x11/kdelibs4/files/patch-git_e405fa9
deleted file mode 100644
index 64f3b0320dba..000000000000
--- a/x11/kdelibs4/files/patch-git_e405fa9
+++ /dev/null
@@ -1,153 +0,0 @@
-commit e405fa978b3c308249a5d553b784d3f8b277fd35
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Wed Jul 18 22:32:41 2012 -0300
-
- HAL: Use the filtering code in HalDevice in devicesFromQuery().
-
- Follow what other backends such as the UDisks one do and simply relay
- the required checks for validity to each Device we are interested in.
-
- So far, HalDevice::queryDeviceInterface() performed some checks
- depending on the DeviceInterface type being passed to it, while
- HalManager::devicesFromQuery() did not filter the results it got in
- the same way. What's more, some checks such as the video4linux ones
- were being made in both places, leading to some needless duplication
- in functionality.
-
- As a side-effect, this fixes a bug made visibile by a recent commit to
- libktorrent: retrieving StorageAccess devices with listFromType()
- would simply query HAL for devices with the "volume" capability (which
- includes swap partitions and other non-mountable things), so using
- Device::asDeviceInterface(Solid::DeviceInterface::StorageAccess) would
- sometimes return 0 on a few of those entries retrieved earlier.
-
- Reviewed-by: Alberto Villa <avilla@FreeBSD.org>
- REVIEW: 105615
-
-diff --git a/solid/solid/backends/hal/halmanager.cpp b/solid/solid/backends/hal/halmanager.cpp
-index 2c9c6c0..7238b6a 100644
---- solid/solid/backends/hal/halmanager.cpp
-+++ solid/solid/backends/hal/halmanager.cpp
-@@ -147,30 +147,27 @@ bool HalManager::deviceExists(const QString &udi)
- QStringList HalManager::devicesFromQuery(const QString &parentUdi,
- Solid::DeviceInterface::Type type)
- {
-- if (!parentUdi.isEmpty())
-- {
-- QStringList result = findDeviceStringMatch("info.parent", parentUdi);
-+ if ((parentUdi.isEmpty()) && (type == Solid::DeviceInterface::Unknown)) {
-+ return allDevices();
-+ }
-
-- if (type!=Solid::DeviceInterface::Unknown) {
-- const QStringList matches = result;
-- result.clear();
-+ QStringList result;
-
-- foreach (const QString &match, matches) {
-- HalDevice device(match);
-+ foreach (const QString &udi, allDevices()) {
-+ HalDevice device(udi);
-
-- if (device.queryDeviceInterface(type)) {
-- result << match;
-- }
-- }
-+ if ((!parentUdi.isEmpty()) && (parentUdi != device.parentUdi())) {
-+ continue;
- }
-
-- return result;
-+ if ((type != Solid::DeviceInterface::Unknown) && (!device.queryDeviceInterface(type))) {
-+ continue;
-+ }
-
-- } else if (type!=Solid::DeviceInterface::Unknown) {
-- return findDeviceByDeviceInterface(type);
-- } else {
-- return allDevices();
-+ result << udi;
- }
-+
-+ return result;
- }
-
- QObject *HalManager::createDevice(const QString &udi)
-@@ -182,63 +179,6 @@ QObject *HalManager::createDevice(const QString &udi)
- }
- }
-
--QStringList HalManager::findDeviceStringMatch(const QString &key, const QString &value)
--{
-- QDBusReply<QStringList> reply = d->manager.call("FindDeviceStringMatch", key, value);
--
-- if (!reply.isValid())
-- {
-- qWarning() << Q_FUNC_INFO << " error: " << reply.error().name() << endl;
-- return QStringList();
-- }
--
-- return reply;
--}
--
--QStringList HalManager::findDeviceByDeviceInterface(Solid::DeviceInterface::Type type)
--{
-- QStringList cap_list = DeviceInterface::toStringList(type);
-- QStringList result;
--
-- foreach (const QString &cap, cap_list)
-- {
-- QDBusReply<QStringList> reply = d->manager.call("FindDeviceByCapability", cap);
--
-- if (!reply.isValid())
-- {
-- qWarning() << Q_FUNC_INFO << " error: " << reply.error().name() << endl;
-- return QStringList();
-- }
-- if ( cap == QLatin1String( "video4linux" ) )
-- {
-- QStringList foundDevices ( reply );
-- QStringList filtered;
-- foreach ( const QString &udi, foundDevices )
-- {
-- QDBusInterface device( "org.freedesktop.Hal", udi, "org.freedesktop.Hal.Device", QDBusConnection::systemBus() );
-- QDBusReply<QString> reply = device.call( "GetProperty", "video4linux.device" );
-- if (!reply.isValid())
-- {
-- qWarning() << Q_FUNC_INFO << " error getting video4linux.device: " << reply.error().name() << endl;
-- continue;
-- }
-- if ( !reply.value().contains( "video" ) )
-- {
-- continue;
-- }
-- filtered.append( udi );
-- }
-- result += filtered;
-- }
-- else
-- {
-- result << reply;
-- }
-- }
--
-- return result;
--}
--
- void HalManager::slotDeviceAdded(const QString &udi)
- {
- d->devicesCache.append(udi);
-diff --git a/solid/solid/backends/hal/halmanager.h b/solid/solid/backends/hal/halmanager.h
-index ec42fac..377b15d 100644
---- solid/solid/backends/hal/halmanager.h
-+++ solid/solid/backends/hal/halmanager.h
-@@ -59,9 +59,6 @@ private Q_SLOTS:
- void slotDeviceRemoved(const QString &udi);
-
- private:
-- QStringList findDeviceStringMatch(const QString &key, const QString &value);
-- QStringList findDeviceByDeviceInterface(Solid::DeviceInterface::Type type);
--
- HalManagerPrivate *d;
- };
- }
diff --git a/x11/kdelibs4/files/patch-kdecore__CMakeLists.txt b/x11/kdelibs4/files/patch-kdecore__CMakeLists.txt
deleted file mode 100644
index 3b2a1e56ebbe..000000000000
--- a/x11/kdelibs4/files/patch-kdecore__CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./kdecore/CMakeLists.txt.orig 2012-06-07 07:54:04.000000000 +1100
-+++ ./kdecore/CMakeLists.txt 2012-06-17 05:04:23.000000000 +1100
-@@ -385,7 +385,7 @@
- set(kdecore_OPTIONAL_LIBS ${kdecore_OPTIONAL_LIBS} ${CMAKE_THREAD_LIBS_INIT})
-
- set_source_files_properties(util/kshareddatacache.cpp
-- PROPERTIES COMPILE_FLAGS ${KDE4_ENABLE_EXCEPTIONS})
-+ PROPERTIES COMPILE_FLAGS "${KDE4_ENABLE_EXCEPTIONS}")
- else(NOT WIN32)
- set(kdecore_LIB_SRCS ${kdecore_LIB_SRCS} util/kshareddatacache_win.cpp)
- set(kdecore_LIB_SRCS ${kdecore_LIB_SRCS} io/kdirwatch_win.cpp)
diff --git a/x11/kdelibs4/files/patch-kparts__componentfactory.h b/x11/kdelibs4/files/patch-kparts__componentfactory.h
deleted file mode 100644
index 4332929cfc69..000000000000
--- a/x11/kdelibs4/files/patch-kparts__componentfactory.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- kparts/componentfactory.h.orig 2012-11-23 16:20:14.000000000 +0800
-+++ kparts/componentfactory.h 2012-11-23 16:20:22.000000000 +0800
-@@ -28,6 +28,8 @@
- #endif
- #include <kmimetypetrader.h>
-
-+#include <QtCore/QFile>
-+
- namespace KParts
- {
- namespace ComponentFactory
-@@ -81,7 +83,7 @@
- const QStringList &args = QStringList(),
- int *error = 0 )
- {
-- KLibrary *library = KLibLoader::self()->library( QString( libraryName ) ); // compatibility hack
-+ KLibrary *library = KLibLoader::self()->library( QFile::decodeName( libraryName ) ); // compatibility hack
- if ( !library )
- {
- if ( error )
-@@ -135,7 +137,7 @@
- return 0;
- }
-
-- return createPartInstanceFromLibrary<T>( library.toLocal8Bit().data(), parentWidget,
-+ return createPartInstanceFromLibrary<T>( QFile::encodeName( library ).constData(), parentWidget,
- parent, args, error );
- }
- #endif
diff --git a/x11/kdelibs4/files/patch-mimetypes_kde.xml b/x11/kdelibs4/files/patch-mimetypes_kde.xml
index d89a761cb0b4..c3b051f76532 100644
--- a/x11/kdelibs4/files/patch-mimetypes_kde.xml
+++ b/x11/kdelibs4/files/patch-mimetypes_kde.xml
@@ -1,5 +1,5 @@
---- ./mimetypes/kde.xml.orig 2012-01-11 01:17:51.000000000 +1100
-+++ ./mimetypes/kde.xml 2012-05-14 20:50:05.000000000 +1100
+--- ./mimetypes/kde.xml.orig 2012-09-27 17:09:06.000000000 -0700
++++ ./mimetypes/kde.xml 2012-10-26 14:22:51.802005859 -0700
@@ -13,11 +13,6 @@
the mime type there.
-->
@@ -27,7 +27,7 @@
<mime-type type="application/x-plasma">
<sub-class-of type="application/zip"/>
<comment>plasmoid</comment>
-@@ -152,9 +139,6 @@
+@@ -148,9 +135,6 @@
<glob pattern="*.pnx"/>
<glob pattern="*.rdc"/>
</mime-type>
@@ -37,7 +37,7 @@
<mime-type type="text/x-hex">
<sub-class-of type="text/plain"/>
<comment>IntelĀ® hexadecimal object file</comment>
-@@ -355,28 +339,10 @@
+@@ -351,27 +335,6 @@
<glob pattern="*.wmp"/>
</mime-type>
@@ -45,10 +45,6 @@
- <comment>shortcut to Kexi project on database server</comment>
- <glob pattern="*.kexis"/>
- </mime-type>
- <mime-type type="application/x-kexiproject-sqlite"> <!-- FIXED 0.70 -->
- <comment>Kexi database file-based project</comment>
- <glob pattern="*.kexi"/>
- </mime-type>
- <mime-type type="application/x-kexiproject-sqlite2"> <!-- FIXED 0.70 -->
- <sub-class-of type="application/x-sqlite2"/>
- <comment>Kexi database file-based project</comment>
@@ -58,15 +54,18 @@
- <sub-class-of type="application/x-sqlite3"/>
- <comment>Kexi database file-based project</comment>
- <glob pattern="*.kexi"/>
+- <alias type="application/x-kexiproject-sqlite"/>
+- <alias type="application/x-vnd.kde.kexi"/>
- </mime-type>
- <mime-type type="application/x-kexi-connectiondata"> <!-- FIXED 0.70 -->
- <comment>data for database server connection</comment>
- <glob pattern="*.kexic"/>
- </mime-type>
-
+-
<!-- http://www4.wiwiss.fu-berlin.de/bizer/TriG/ -->
<!-- Used in Nepomuk to encode almost all ontologies -->
-@@ -398,25 +364,4 @@
+ <mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="application/x-trig"> <!-- fdo #18089 -->
+@@ -392,25 +355,4 @@
</magic>
<glob pattern="*.pic"/>
</mime-type>